Bug 1544787 - tests/bugs/cli/bug-1169302.t fails spuriously
Summary: tests/bugs/cli/bug-1169302.t fails spuriously
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1542054
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-13 13:56 UTC by Atin Mukherjee
Modified: 2018-03-10 12:37 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1542054
Environment:
Last Closed: 2018-03-10 12:37:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2018-02-13 13:56:33 UTC
+++ This bug was initially created as a clone of Bug #1542054 +++

Description of problem:

tests/bugs/cli/bug-1169302.t fails spuriously

Fix https://review.gluster.org/#/c/18893/ to be backported into release-3.12.


Version-Release number of selected component (if applicable):
3.12

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-02-05 08:30:32 EST ---

REVIEW: https://review.gluster.org/19501 (tests: Fix a broken test case) posted (#1) for review on release-3.12 by Atin Mukherjee

--- Additional comment from Worker Ant on 2018-02-05 09:29:30 EST ---

COMMIT: https://review.gluster.org/19501 committed in release-3.12 by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- tests: Fix a broken test case

Issue: When using statedump command to take statedump of the
gfapi process, we specify the following things:

$gluster volume statedump <volname> client <host>:<pid>
   pid: Pid of the gfapi application
   host: This should be the IP/hostname as seen by the glusterd,
         the gfapi application is connected to.

In this test case, if gfapi application is running locally,
and is connected to $H1 glusterd, the <host> need not be $H1.
<host> could be localhost, 127.0.0.1, 127.1.1.1 etc. based on
the configuration of the system. Hence use netstat to find the
right <host> value.

>mainline patch : https://review.gluster.org/#/c/18893/

Change-Id: I6efb9d1ccaf9c6841a9ab7c9ebfecafc03c0bc5e
BUG: 1542054
Signed-off-by: Poornima G <pgurusid@redhat.com>

Comment 1 Worker Ant 2018-02-13 14:05:15 UTC
REVIEW: https://review.gluster.org/19562 (tests: Fix a broken test case) posted (#1) for review on release-3.10 by Atin Mukherjee

Comment 2 Worker Ant 2018-02-15 14:09:48 UTC
COMMIT: https://review.gluster.org/19562 committed in release-3.10 by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- tests: Fix a broken test case

Issue: When using statedump command to take statedump of the
gfapi process, we specify the following things:

$gluster volume statedump <volname> client <host>:<pid>
   pid: Pid of the gfapi application
   host: This should be the IP/hostname as seen by the glusterd,
         the gfapi application is connected to.

In this test case, if gfapi application is running locally,
and is connected to $H1 glusterd, the <host> need not be $H1.
<host> could be localhost, 127.0.0.1, 127.1.1.1 etc. based on
the configuration of the system. Hence use netstat to find the
right <host> value.

>mainline patch : https://review.gluster.org/#/c/18893/

Change-Id: I6efb9d1ccaf9c6841a9ab7c9ebfecafc03c0bc5e
BUG: 1544787
Signed-off-by: Poornima G <pgurusid@redhat.com>
(cherry picked from commit 5529659dec7607bf9b94ea2195672ae553458785)

Comment 3 Shyamsundar 2018-03-10 12:37:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.11, please open a new bug report.

glusterfs-3.10.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000091.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.