Bug 1542112 - docker-common dropped Requires on oci-register-machine without changelog or BZ
Summary: docker-common dropped Requires on oci-register-machine without changelog or BZ
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-05 15:22 UTC by Jon Schlueter
Modified: 2019-03-06 00:58 UTC (History)
9 users (show)

Fixed In Version: docker-1.13.1-47.gitec9911e.el7_4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-07 09:51:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1542066 urgent CLOSED [OSP13]OC deployment was fail due to "Error: /Stage[main]/Tripleo::Profile::Base::Docker/File_line[configure-oci-registe... 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2018:0436 normal SHIPPED_LIVE docker bug fix and enhancement update 2018-03-07 14:51:35 UTC

Internal Links: 1542066

Description Jon Schlueter 2018-02-05 15:22:21 UTC
Description of problem:

observed the removal of the Req without any changelog or bz describing the reason for the change.

Version-Release number of selected component (if applicable):

docker-1.13.1-45.gitec9911e.el7


How reproducible:

Always


Steps to Reproduce:
1. yum install docker-common-1.13.1-45.gitec9911e.el7
2. rpm -qa | grep oci-register-machine
3. look at .spec changelog  which doesn't have any reference to the change either.

Actual results:
not installed
no changelog entry

Expected results:

Either installed or changelog/bz for why it's no-longer Required

Additional info:

Comment 3 Lokesh Mandvekar 2018-02-05 15:26:02 UTC
My mistake here, I'll revert the change, but oci-register-machine will be kept disabled via config file.

Comment 7 Emilien Macchi 2018-02-05 16:47:20 UTC
Please backport to rhel-7.4 and rhel-7.5 as well. It broke our CI jobs for OpenStack.

Thanks

Comment 8 Emilien Macchi 2018-02-05 16:50:07 UTC
*** Bug 1542066 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-03-07 09:51:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0436


Note You need to log in before you can comment on or make changes to this bug.