Bug 1542066 - [OSP13]OC deployment was fail due to "Error: /Stage[main]/Tripleo::Profile::Base::Docker/File_line[configure-oci-register-machine]: Could not evaluate: No such file or directory - /etc/oci-register-machine.conf"
Summary: [OSP13]OC deployment was fail due to "Error: /Stage[main]/Tripleo::Profile::B...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1553291
TreeView+ depends on / blocked
 
Reported: 2018-02-05 13:41 UTC by Artem Hrechanychenko
Modified: 2018-06-27 13:44 UTC (History)
9 users (show)

Fixed In Version: puppet-tripleo-8.2.0-0.20180122224520.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1553291 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:43:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
stack failures list long (760.62 KB, text/plain)
2018-02-05 13:51 UTC, Artem Hrechanychenko
no flags Details
sosreport from UC (19.19 MB, application/x-xz)
2018-02-05 13:52 UTC, Artem Hrechanychenko
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 540930 None master: NEW puppet-tripleo: Revert "Set disable:true for oci-machine-register" (Iddc8a35a20a745dba14456e4b57741ffec67cc80) 2018-02-05 20:16:42 UTC
Red Hat Bugzilla 1542112 None None None Never
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:44:12 UTC

Internal Links: 1542112

Description Artem Hrechanychenko 2018-02-05 13:41:40 UTC
Description of problem:
Deployment of OSP13 OC with composable roles - 3 X Controllers + 1 X Computes + 3 X ceph + 3 X Database + 3 X Messaging + 2 Networker + Undercloud SSL + Overcloud SSL was fail

....
overcloud.AllNodesDeploySteps.ComputeDeployment_Step1.0:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: d02bd321-fdb7-4256-bf8a-65c4b9e6460d
  status: CREATE_FAILED
  status_reason: |
    Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
            "                    with Stdlib::Compat::Numeric. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ntp/manifests/init.pp\", 76]:[\"/etc/puppet/modules/tripleo/manifests/profile/base/time/ntp.pp\", 29]",
            "                    with Stdlib::Compat::Hash. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ssh/manifests/server.pp\", 12]:[\"/var/lib/tripleo-config/puppet_step_config.pp\", 41]",
            "Error: /Stage[main]/Tripleo::Profile::Base::Docker/File_line[configure-oci-register-machine]: Could not evaluate: No such file or directory - /etc/oci-register-machine.conf"
        ]
    }
        to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/caa68464-578c-4198-8156-be3617f7e0ec_playbook.retry
   
    PLAY RECAP *********************************************************************
    localhost                  : ok=4    changed=1    unreachable=0    failed=1  
   
    (truncated, view all with --long)
  deploy_stderr: |
....



Version-Release number of selected component (if applicable):
openstack-zaqar-6.0.0-0.20180123030653.1feeb36.el7ost.noarch
openstack-nova-placement-api-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
openstack-selinux-0.8.13-0.20180108164838.c6158ce.el7ost.noarch
openstack-glance-16.0.0-0.20180123074513.466c104.el7ost.noarch
openstack-swift-object-2.15.2-0.20180118220641.449d83f.el7ost.noarch
openstack-neutron-openvswitch-12.0.0-0.20180123043113.d32ad6e.el7ost.noarch
openstack-heat-api-10.0.0-0.20180123134729.85a3e98.el7ost.noarch
openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost.noarch
openstack-mistral-engine-6.0.0-0.20180122153726.ae7950e.el7ost.noarch
openstack-ironic-common-10.0.1-0.20180123173432.2c630d9.el7ost.noarch
openstack-swift-account-2.15.2-0.20180118220641.449d83f.el7ost.noarch
openstack-heat-engine-10.0.0-0.20180123134729.85a3e98.el7ost.noarch
openstack-tripleo-ui-8.1.1-0.20180122135122.aef02d8.el7ost.noarch
openstack-puppet-modules-11.0.0-0.20171011152327.71ad01c.el7ost.noarch
openstack-tripleo-image-elements-8.0.0-0.20180117094122.02d0985.el7ost.noarch
openstack-nova-api-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
openstack-nova-conductor-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
openstack-nova-compute-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
openstack-neutron-ml2-12.0.0-0.20180123043113.d32ad6e.el7ost.noarch
openstack-swift-proxy-2.15.2-0.20180118220641.449d83f.el7ost.noarch
openstack-heat-common-10.0.0-0.20180123134729.85a3e98.el7ost.noarch
openstack-ironic-conductor-10.0.1-0.20180123173432.2c630d9.el7ost.noarch
openstack-tempest-17.2.1-0.20180123175631.fe655fe.el7ost.noarch
openstack-mistral-api-6.0.0-0.20180122153726.ae7950e.el7ost.noarch
openstack-tripleo-validations-8.1.1-0.20180119231917.2ff3c79.el7ost.noarch
python2-openstacksdk-0.9.19-0.20171105041723.bd60aa4.el7ost.noarch
openstack-neutron-12.0.0-0.20180123043113.d32ad6e.el7ost.noarch
puppet-openstack_extras-12.2.0-0.20180119072029.b090b97.el7ost.noarch
openstack-tripleo-common-containers-8.3.1-0.20180123050219.el7ost.noarch
openstack-nova-common-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
openstack-swift-container-2.15.2-0.20180118220641.449d83f.el7ost.noarch
openstack-neutron-common-12.0.0-0.20180123043113.d32ad6e.el7ost.noarch
python2-openstackclient-3.13.0-0.20180109064941.8c5f755.el7ost.noarch
openstack-heat-api-cfn-10.0.0-0.20180123134729.85a3e98.el7ost.noarch
openstack-ironic-staging-drivers-0.8.1-0.20180118014800.ae60c0b.el7ost.noarch
openstack-tripleo-puppet-elements-8.0.0-0.20180117092204.120eca8.el7ost.noarch
openstack-tripleo-common-8.3.1-0.20180123050219.el7ost.noarch
openstack-mistral-executor-6.0.0-0.20180122153726.ae7950e.el7ost.noarch
openstack-nova-scheduler-17.0.0-0.20180123163703.27eadbc.el7ost.noarch
python-openstackclient-lang-3.13.0-0.20180109064941.8c5f755.el7ost.noarch
openstack-keystone-13.0.0-0.20180123044720.9cd5f19.el7ost.noarch
openstack-ironic-api-10.0.1-0.20180123173432.2c630d9.el7ost.noarch
openstack-ironic-inspector-7.0.1-0.20180122225049.0cf3316.el7ost.noarch
puppet-openstacklib-12.2.0-0.20180119083603.12107fd.el7ost.noarch
openstack-mistral-common-6.0.0-0.20180122153726.ae7950e.el7ost.noarch


How reproducible:


Steps to Reproduce:
1.http://staging-jenkins2-qe-playground.usersys.redhat.com/job/DFG-df-13_director-rhel-7.4-virthost-3cont_1comp_3ceph_3db_2net_3msg-yes_UC_SSL-yes_OC_SSL-ceph-ipv4-vxlan-RHELOSP-31891-poc/1/consoleFull


Actual results:
overcloud deployment was fail

Expected results:
overcloud deployment was finish

Additional info:

Comment 2 Artem Hrechanychenko 2018-02-05 13:51:57 UTC
Created attachment 1391527 [details]
stack failures list long

Comment 3 Artem Hrechanychenko 2018-02-05 13:52:56 UTC
Created attachment 1391528 [details]
sosreport from UC

Comment 4 Emilien Macchi 2018-02-05 16:50:07 UTC

*** This bug has been marked as a duplicate of bug 1542112 ***

Comment 7 Alexander Chuzhoy 2018-02-07 22:10:40 UTC
Reproducible without composable roles too. Used the following command:
openstack overcloud deploy \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack overcloud \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation-v6.yaml \
-e /home/stack/virt/network/network-environment-v6.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml \
-e /home/stack/virt/hostnames.yml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker-ha.yaml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e /home/stack/virt/docker-images.yaml


(undercloud) [stack@undercloud-0 ~]$ cat virt/nodes_data.yaml 
parameter_defaults:
    ControllerCount: 3
    OvercloudControlFlavor: controller
    ComputeCount: 3
    OvercloudComputeFlavor: compute
    CephStorageCount: 3
    OvercloudCephStorageFlavor: ceph

Comment 8 Artem Hrechanychenko 2018-02-13 15:17:43 UTC
Looks like fix already in puddle but bz is still on POST

Comment 11 errata-xmlrpc 2018-06-27 13:43:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.