Bug 1543044 - [3.7] Failed to unbind after deleting templateinstance with servicebinding existing
Summary: [3.7] Failed to unbind after deleting templateinstance with servicebinding ex...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.z
Assignee: Ben Parees
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On: 1540819
Blocks: 1543039
TreeView+ depends on / blocked
 
Reported: 2018-02-07 15:46 UTC by Ben Parees
Modified: 2018-06-07 12:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Unbinding a template service instance throws an error if the template service instance was deleted. Consequence: It becomes impossible to unbind a service instance if the template service instance was manually deleted, including if the project containing the TSI was deleted. Fix: The template service broker will return success/gone in cases where the unbind refers to a non-existent template service instance. Result: The unbind can proceed even if the TSI no longer exists.
Clone Of: 1540819
Environment:
Last Closed: 2018-06-07 12:40:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:39:21 UTC

Comment 3 XiuJuan Wang 2018-02-13 06:23:59 UTC
Could unbind after deleting templateinstance with servicebinding existing.
Can't reproduce this bug in ocp v3.7.29 with service-catalog(image id ce5cecc95a66) and ose(image id 67270b3564b7) images

Comment 7 errata-xmlrpc 2018-04-05 09:38:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.