Bug 154448 - Right "windows key" generates mouse button events
Right "windows key" generates mouse button events
Status: CLOSED DUPLICATE of bug 157156
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 155792 158516 (view as bug list)
Depends On: 157156
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-04-11 16:06 EDT by Göran Uddeborg
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 07:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file in use (3.21 KB, text/plain)
2005-04-11 16:08 EDT, Göran Uddeborg
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3058 None None None Never

  None (edit)
Description Göran Uddeborg 2005-04-11 16:06:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
When I press the right "window" key, between AltGr and the menu key on my Swedish keyboard, it generates mouse button events rather than key events.  More specifically, when I press the key, it generates ButtonPress and ButtonRelease for button 6, and when I release it it generates ButtonPress and ButtonRelease for button 7.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-7 kernel-2.6.11-1.1225_FC4

How reproducible:
Always

Steps to Reproduce:
1.Press and release the right window key.

Additional info:

I'm not at all sure this bug is in xorg-x11.  It could of course be in some underlying system.

The keyboard I use has a Swedish layout.  I've tried with two different keyboards with the same effect.  Both have Swedish layout, but different manufacturers.  Under Windows, the key behaves normally.
Comment 1 Göran Uddeborg 2005-04-11 16:08:07 EDT
Created attachment 112987 [details]
xorg.conf file in use
Comment 2 Mike A. Harris 2005-04-15 09:57:11 EDT
If this issue turns out to still be reproduceable in the latest
updates for this Fedora Core release, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO", and awaiting upstream bug report
URL for tracking.

Thanks in advance.
Comment 3 Göran Uddeborg 2005-04-18 11:33:29 EDT
I've created bug 3058 at X.org.  I tried to fill in the appropriate field here
too, but just in case I got it wrong, the URL is
https://bugs.freedesktop.org/show_bug.cgi?id=3058

Should I change status to ASSIGNED too?  Or should that be done when the
upstreams bug is closed?
Comment 4 Göran Uddeborg 2005-04-21 07:28:08 EDT
I did a test by installing the recent kernel (2.6.11-1.1226_FC4) on a machine
with otherwise older packages.  Now I see this problem on that machine too! 
Only the kernel was changed.

This is of course not a proof this is a kernel bug.  But it seems changes in the
kernel are involved.

What do you suggest I do with this bugzilla?  Should I reassign to the kernel
component?  I'm uncertain how to best handle the situation.
Comment 5 Matthias Clasen 2005-04-23 01:12:24 EDT
*** Bug 155792 has been marked as a duplicate of this bug. ***
Comment 6 Göran Uddeborg 2005-05-07 15:30:24 EDT
Experimenting a bit I discovered the key behaves strangely without X too.  It is
reported as bug 157156.  It seems likely that bug could be the underlying
problem for these problems too.  But I'm not sure, so I reported it separately.
Comment 7 Olivier Crête 2005-05-18 15:04:39 EDT
me too... on fc4 t3 (with xorg-x11 updated using yum).. and I still experience
that bug... with the ca_enhanced keymap, there are also a bunch of keys that are
outputting the keysyms... And I'm using a very standard ps2 keyboard (no fancy
usb stuff). 
Comment 8 Dov Grobgeld 2005-05-23 04:13:23 EDT
*** Bug 158516 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Britov 2005-06-06 09:10:33 EDT
I'm using Fedora rawhide on my desktop from FC2.
And I think (afair) I get this problem after xorg updates about 3 monthes ago.
AFAIR!
I may be wrong. I'm test it on FC and generic kernels.
Comment 10 Gérard Milmeister 2005-06-18 11:56:43 EDT
I am using FC4 final, and have the same problem. The right windows key generates
a button 4 event according to xev. In Linux console the key does not generate
anything according to showkey.
Comment 11 Maxim Britov 2005-06-21 05:14:53 EDT
Bug seems fixed in rawhide xorg-x11-6.8.2-38
Thanks.
Comment 12 Göran Uddeborg 2005-06-22 18:58:24 EDT
I installed xorg-x11*-6.8.2-38 on an FC4 installation, and still have the
problem.    Maxim, when you saw the bug fixed, what version were the rest of the
system.  In particular, what kernel did you use.  (As I mentioned in comment 6,
there are some strange issues with the key outside X too.  This might not be an
X problem.)
Comment 13 Maxim Britov 2005-06-24 06:02:51 EDT
Then It may be kernel bug. I use generic 2.6.12 now. I'm sorry.
Comment 14 Göran Uddeborg 2005-06-27 17:09:16 EDT
Don't be sorry!  You gave another bit of information: that current xorg-x11 and
a generic 2.6.12 does not cause the problem.  That is another indication this is
really a kernel bug.

At least it's probably a good idea not to do anything with this one until bug
157156 has been investigated.  I'll put a "depends on" here to mark that.
Comment 15 Juliano F. Ravasi 2005-07-01 23:21:43 EDT
Please, someone explain this to me: We are talking about keyboard generating
mouse events... we have different devices, different cables, different ports,
different protocols, different kernel drivers and different X11 input drivers...
They are very independent from each other... How could be that a key pressed on
the keyboard generates a mouse scroll event?
Comment 16 Thorsten Leemhuis 2005-07-02 06:45:10 EDT
Just stumbled over this bug. Is this thread / patch any help:

http://lkml.org/lkml/2005/5/26/119
Comment 17 Göran Uddeborg 2005-07-06 07:38:15 EDT
The problems goes away with the kernel upgrade.  So it seems this wasn't an X issue.

*** This bug has been marked as a duplicate of 157156 ***

Note You need to log in before you can comment on or make changes to this bug.