Bug 157156 - Right "windows key" doesn't generate any key events
Right "windows key" doesn't generate any key events
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 154448 (view as bug list)
Depends On:
Blocks: 154448
  Show dependency treegraph
 
Reported: 2005-05-07 15:26 EDT by Göran Uddeborg
Modified: 2015-01-04 17:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 07:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2005-05-07 15:26:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050309 Fedora/1.7.6-0.cvs.20050309

Description of problem:
There are no key events from the right "windows" key.  If I on a virtual console run "showkey -s", nothing is printed when I press the right hand "windows key".

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1226_FC4

How reproducible:
Always

Steps to Reproduce:
1.Run showkey -s
2.Press right hand side "windows key".

Actual Results:  Nothing

Expected Results:  Some scan codes

Additional info:

I'm using a Swedish keyboard.  /etc/sysconfig/keyboard has KEYBOARDTYPE="pc" and KEYTABLE="sv-latin1".  It worked fine with FC3 and older kernels.

I suspect this bug could be the underlying reason for the problems I reported in bug 154448.  With xev this key reports mouse events.  But I know too little about how X do things so I'm not sure, and report it separately.
Comment 1 Kris Ven 2005-06-23 16:28:46 EDT
I'm confirming this behavior with FC4 final. Running 'showkey -s' does not
record it when the right windows key is pressed. The left windows key is
recognized however.

In X Windows (KDE/Gnome), xev reports the key as mouse button 4 (scroll up).
Comment 2 Dave Jones 2005-06-27 19:12:32 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 3 Göran Uddeborg 2005-06-29 08:51:59 EDT
Kris Ven had already confirmed it in FC4 final in comment 1.  Now I too have
tested it there, with all patches applied.  The bug is still there.
Comment 4 Göran Uddeborg 2005-07-02 17:39:24 EDT
After installing kernel-2.6.12-1.1387_FC4 the problem appears to be gone.  The
key shows up with shwokey, and also behaves correctly in X again.
Comment 5 Kris Ven 2005-07-03 05:58:43 EDT
I cannot confirm whether the new kernel (2.6.12-1.1387_FC4) solves the problem,
since it kernel panics on boot up. I'll have to file/search a separate bug
report for that first. I'll report on this bug, once I got the new kernel working.
Comment 6 Göran Uddeborg 2005-07-06 07:33:00 EDT
I've verified some more (on i386 and x86_64), and am convinced this is solved
with the 2.6.12 kernel.  If you should find otherwise Kris Ven, reopen.  (Or
file a new.)
Comment 7 Göran Uddeborg 2005-07-06 07:38:44 EDT
*** Bug 154448 has been marked as a duplicate of this bug. ***
Comment 8 Kris Ven 2005-07-07 13:38:57 EDT
I installed the kernel on a different machine on which the kernel *does* work,
and the problem has disappeared. This bug has indeed been solved.

Note You need to log in before you can comment on or make changes to this bug.