Bug 154572 - en install with CJK language selections missing IIIMF requirements
Summary: en install with CJK language selections missing IIIMF requirements
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-12 19:05 UTC by Aaron Kurtz
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: anaconda-10.2.1.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-27 01:30:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart script generated from the installation (1.07 KB, text/plain)
2005-05-23 08:16 UTC, Lawrence Lim
no flags Details
install log from the installation (61.18 KB, text/plain)
2005-05-23 08:17 UTC, Lawrence Lim
no flags Details
install log syslog from the installation (5.82 KB, text/plain)
2005-05-23 08:18 UTC, Lawrence Lim
no flags Details

Description Aaron Kurtz 2005-04-12 19:05:29 UTC
Description of problem:
First off, good work on putting language selection back into FC. I think having
it part of the package selection process instead of a seperate step is a good
thing too, as the way it's presented is much cleaner. Unfortunately, it doesn't
install everything required for IIIMF to work.

When I installed the Japanese and Chinese language packs, the IIIMF rpms were:
iiimf-server
iiimf-libs
iiimf-le-cin
iiimf-le-chinput
iiimf-le-canna

while I've found to get this working one really needs:
iiimf-x
iiimf-gtk
and if using Gnome: 
iiimf-gnome-im-switcher

Adding these make IIIMF work.

Comment 1 Wei-Lun Chao 2005-04-20 07:30:56 UTC
This language pack selection also has no default selected item
according to the install language choosed on former screen.

And it has no i18n-message.


Comment 2 Wei-Lun Chao 2005-04-20 07:45:34 UTC
/etc/sysconfig/i18n
must be manually changed.


Comment 3 Wei-Lun Chao 2005-04-21 01:47:41 UTC
also can not automatically load language-specified:
openoffice.org-langpack
mozilla-firefox-langpack (if any)


Comment 4 Elliot Lee 2005-05-11 22:57:39 UTC
Leon, please advise.

Comment 5 Leon Ho 2005-05-16 09:00:11 UTC
By searching in comps.xml, I can see the following. For example for Chinese
support (lang = zh):
...
    <langonly>zh</langonly>
    <packagelist>
      <packagereq type="default">bg5ps</packagereq>
      <packagereq type="optional"
requires="xorg-x11">iiimf-gnome-im-switcher</packagereq>
      <packagereq type="optional" requires="xorg-x11">iiimf-gtk</packagereq>
      <packagereq type="default">iiimf-le-chinput</packagereq>
      <packagereq type="default">iiimf-le-xcin</packagereq>
      <packagereq type="default">iiimf-server</packagereq>
      <packagereq type="optional" requires="xorg-x11">iiimf-x</packagereq>
      <packagereq type="optional" requires="kdelibs">kde-i18n-Chinese</packagereq>
      <packagereq type="optional"
requires="kdelibs">kde-i18n-Chinese-Big5</packagereq>
      <packagereq type="optional">stardict</packagereq>
      <packagereq type="mandatory">taipeifonts</packagereq>
      <packagereq type="mandatory">fonts-chinese</packagereq>
      <packagereq type="optional"
requires="openoffice.org-core">openoffice.org-langpack-zh_CN</packagereq>
      <packagereq type="optional"
requires="openoffice.org-core">openoffice.org-langpack-zh_TW</packagereq>
    </packagelist>
  </group>

Aaron, I assume you have xorg-x11 package with your installation? And Wei-Lun, I
assume you have openoffice.org-core?

If that is the case, it maybe an anaconda bug. 

Comment 6 Jens Petersen 2005-05-16 11:13:47 UTC
Please re-test with fc4test3.  I believe this has been fixed
in rawhide (fc/devel) for a while now.

Comment 7 Jens Petersen 2005-05-16 13:33:12 UTC
Closing, please reopen if you still see problems with fc4test3 or later.

*** This bug has been marked as a duplicate of 149688 ***

Comment 8 Aaron Kurtz 2005-05-16 23:12:26 UTC
This is slightly different from the issue of the default language environment.

I just tried out a FC4t3 installation, sha1sum and mediachecked, Desktop option
with the sole exception of adding Chinese and Japanese language packs. Yes,
xorg-x11 is installed, but I still had to install iiimf-gtk, iiimg-x and
iiimg-gnome-im-switcher to get input working. LANG was set to en_US. No OO
langpacks.

Sigh, figured it out. And then I started over using Japanese as the installation
language, and all the IIIMF stuff was properly installed and worked. Japanese
language pack was selected in the package options by default, too, and I added
Chinese. LANG was set to ja_JP, and only the Japanese openoffice langpack was
installed, although the rest of the Chinese setup seems fine.

Maybe I'm wrong, but I expected the langpacks and the IIIMF capability for any
language I select even if I don't run the install in it.

Comment 9 Leon Ho 2005-05-17 01:00:28 UTC
Aaron, so you test cases were:

1. Install Desktop option (Using which language as installation lang?) with
Chinese and Japanese language pack in installation. Result: No iiimf-gtk iiimf-x
and iiimf-gnome-im-switcher installed.

2. Install Desktop option (with Japanese as installation lang) and then add
Chinese as language pack in installation. Result: Everything installed
(including package like openoffice.org-langpack-zh_TW.

Are those correct cases that you performed?

Comment 10 Aaron Kurtz 2005-05-17 01:23:45 UTC
1. was using English as the installation language. Result as you say, and no OO
packs.

2. did not include Chinese OO langpacks, otherwise as you say.

Comment 11 Leon Ho 2005-05-23 07:00:33 UTC
From the info, sounds like it maybe a anaconda bug as comps looks sane. 
Reassigning. 

Comment 13 Lawrence Lim 2005-05-23 08:09:16 UTC
I can reproduce the bug as well. Looking at the anaconda-ks.cfg generated after
the install, langsupport --default=en_US.UTF-8. ja_JP and zh_TW selected during
the anaconda installatio process seems missing.

[root@bane ~]# rpm -qa |grep iiimf
iiimf-libs-12.2-0.7.svn2578
iiimf-le-xcin-0.1.10-1
iiimf-le-chinput-0.3-19
iiimf-le-canna-12.2-0.7.svn2578
iiimf-server-12.2-0.7.svn2578

[root@bane ~]# rpm -qa |grep openoffice
openoffice.org-calc-1.9.100-1
openoffice.org-math-1.9.100-1
openoffice.org-core-1.9.100-1
openoffice.org-draw-1.9.100-1
openoffice.org-impress-1.9.100-1
openoffice.org-writer-1.9.100-1
openoffice.org-graphicfilter-1.9.100-1
openoffice.org-xsltfilter-1.9.100-1


Comment 14 Lawrence Lim 2005-05-23 08:16:43 UTC
Created attachment 114702 [details]
kickstart script generated from the installation

Comment 15 Lawrence Lim 2005-05-23 08:17:44 UTC
Created attachment 114703 [details]
install log from the installation

Comment 16 Lawrence Lim 2005-05-23 08:18:32 UTC
Created attachment 114704 [details]
install log syslog from the installation

Comment 17 Lawrence Lim 2005-05-23 23:49:41 UTC
For ja LANG install with zh_* support, IIIMF gets install OK but not OOo,
noticed that the langpack for zh_* are not installed.

[root@bane ~]# rpm -qa |grep iiimf
iiimf-libs-12.2-0.7.svn2578
iiimf-x-12.2-0.7.svn2578
iiimf-gnome-im-switcher-12.2-0.7.svn2578
iiimf-le-xcin-0.1.10-1
iiimf-le-chinput-0.3-19
iiimf-le-canna-12.2-0.7.svn2578
iiimf-server-12.2-0.7.svn2578
iiimf-gtk-12.2-0.7.svn2578

[root@bane ~]# rpm -qa |grep openoffice
openoffice.org-calc-1.9.100-1
openoffice.org-math-1.9.100-1
openoffice.org-core-1.9.100-1
openoffice.org-draw-1.9.100-1
openoffice.org-impress-1.9.100-1
openoffice.org-writer-1.9.100-1
openoffice.org-langpack-ja_JP-1.9.100-1
openoffice.org-graphicfilter-1.9.100-1
openoffice.org-xsltfilter-1.9.100-1

[root@bane ~]# more /etc/sysconfig/i18n
LANG="ja_JP.UTF-8"
SYSFONT="latarcyrheb-sun16"

Comment 18 Chris Lumens 2005-05-24 17:40:15 UTC
This should be fixed in CVS.  See also bug 158389.

Comment 19 Leon Ho 2005-05-26 00:42:50 UTC
Chris, this is going into FC4 right?

Comment 20 Jeremy Katz 2005-05-26 01:25:51 UTC
Yep, it's in the current anaconda in the tree

Comment 21 Lawrence Lim 2005-05-27 01:30:02 UTC
Confirmed fixed. Tested with anaconda-10.2.1.3-1 in the rawhide-20050526 tree.

[root@phantom ~]# rpm -qa |grep iiimf
iiimf-libs-12.2-4
iiimf-le-xcin-0.1.10-1
iiimf-le-chinput-0.3-19
iiimf-server-12.2-4
iiimf-x-12.2-4
iiimf-le-canna-12.2-4
iiimf-gnome-im-switcher-12.2-4
iiimf-gtk-12.2-4

[root@phantom ~]# rpm -qa |grep openoffice.org
openoffice.org-draw-1.9.104-2
openoffice.org-langpack-zh_CN-1.9.104-2
openoffice.org-xsltfilter-1.9.104-2
openoffice.org-calc-1.9.104-2
openoffice.org-graphicfilter-1.9.104-2
openoffice.org-langpack-ja_JP-1.9.104-2
openoffice.org-langpack-zh_TW-1.9.104-2
openoffice.org-writer-1.9.104-2
openoffice.org-core-1.9.104-2
openoffice.org-impress-1.9.104-2
openoffice.org-math-1.9.104-2

[root@phantom ~]# rpm -qa |grep font
bitstream-vera-fonts-1.10-5
bitmap-fonts-0.3-4
taipeifonts-1.2-26
fonts-xorg-100dpi-6.8.2-1
kon2-fonts-0.3.9b-26
fontconfig-2.2.3-13
ghostscript-fonts-5.50-13
xorg-x11-font-utils-6.8.2-31
chkfontpath-1.10.0-4
fonts-japanese-0.20050222-3
fonts-xorg-75dpi-6.8.2-1
urw-fonts-2.3-1
fonts-chinese-2.15-2
fonts-xorg-base-6.8.2-1



Note You need to log in before you can comment on or make changes to this bug.