Bug 149688 - no LANG set in /etc/sysconf/i18n
no LANG set in /etc/sysconf/i18n
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 151593 (view as bug list)
Depends On:
Blocks: 155836
  Show dependency treegraph
 
Reported: 2005-02-25 04:22 EST by Jens Petersen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 13:38:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-02-25 04:22:28 EST
Description of problem:
The language support screen seems to be gone
(going to be replaced with lang package category?),
in the mean time LANG is not being set in /etc/sysconfig/i18n.

How reproducible:
every time.

Steps to Reproduce:
1. install FC in Japanese
  
Actual results:
System runs in Posix locale.

Expected results:
Ideally ja_JP.UTF-8 - well at least LANG to be set
to a utf8 locale. :)
Comment 1 Jeremy Katz 2005-03-14 11:56:08 EST
langsupport screen is intentionally gone.  I'd think /etc/sysconfig/i18n should
still be getting setup properly.  Although might be that we need to explicitly
base some more things off of the InstallTimeLanguage (or really merge it with
Language, which is probably smarter).

Chris -- can you take a look at this?
Comment 2 Chris Lumens 2005-03-21 09:34:13 EST
*** Bug 151593 has been marked as a duplicate of this bug. ***
Comment 3 Ronny Buchmann 2005-03-23 15:50:33 EST
rawhide 2005-03-23:

/etc/sysconfig/i18n SUPPORTED is set, LANG is missing

to comment #1
Does that mean adding languages after installation (with yum groupinstall) is
kind of "supported"?
Comment 4 Chris Lumens 2005-03-31 21:12:31 EST
I've committed a fix for this to Rawhide, so it should appear in the next
anaconda build.  There are still a few more language-related bugs to take care
of so you may encounter some more problems.  Should be a few more days before
everything clears up.
Comment 5 Ronny Buchmann 2005-04-24 10:16:42 EDT
rawhide 2005-04-23 (anaconda 10.2.0.52) - graphical CD install

SUPPORTED and LANG are set to en_US

language selected in installation was German
Comment 6 Ronny Buchmann 2005-04-24 10:23:49 EDT
please reopen
Comment 7 Ronny Buchmann 2005-04-24 12:42:10 EDT
LANG is set properly when doing text mode language selection
Comment 8 Jens Petersen 2005-04-24 21:34:09 EDT
[Re-openning as per comment 6.]
Ronny, next time please feel free to re-open by yourself.

I have only tested installs with boot.iso, which have been fine.
Comment 9 Ronny Buchmann 2005-04-25 13:18:48 EDT
comment #8: 
Jens, it seems only reporter (and maybe *@redhat.com) can reopen.

Try boot.iso with "linux nopass", otherwise you get the language selection from
1st stage loader, wich is working.
Comment 10 Jens Petersen 2005-05-16 09:33:36 EDT
*** Bug 154572 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.