Bug 1546780 - Can't create Octavia Loadbalancer when firewall_driver = openvswitch
Summary: Can't create Octavia Loadbalancer when firewall_driver = openvswitch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 13.0 (Queens)
Hardware: All
OS: Linux
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jakub Libosvar
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks: 1557940
TreeView+ depends on / blocked
 
Reported: 2018-02-19 15:24 UTC by Tomas Sedovic
Modified: 2018-06-27 13:45 UTC (History)
12 users (show)

Fixed In Version: openstack-neutron-12.0.0-0.20180222093624.abb60c6.0rc2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1557940 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:44:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1747082 None None None 2018-02-19 15:24:58 UTC
OpenStack gerrit 550421 'None' MERGED ovs-fw: Clear conntrack information before egress pipeline 2020-03-14 15:27:19 UTC
OpenStack gerrit 554155 'None' MERGED ovs-fw: Clear conntrack information before egress pipeline 2020-03-14 15:27:18 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:38 UTC

Description Tomas Sedovic 2018-02-19 15:24:58 UTC
Description of problem:
When running Neutron with `firewall_driver = openvswitch`, creating a load balancer in Octavia will never complete successfully.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy OSP with Octavia
2. Add `firewall_driver=openvswitch` under `[securitygroup]` in `/etc/neutron/plugins/ml2/openvswitch_agent.ini`
3. Restart neutron-openvswitch-agent
4. Create a load balancer with `openstack loadbalancer create --vip-subnet-id private-subnet --name tst_lb`

Actual results:

The load balancer gets created.


Expected results:

The load balancer is stuck with provisioning_status set to `PENDING_UPDATE`.


Additional info:

According to the upstream report, this bug is in Neutron, however it manifests itself in Octavia.

This is a blocker for Kuryr: we use trunk ports (which in turns requires the openvswitch firewall driver) and we use Octavia to implement the Kubernetes services.

Comment 1 Tomas Sedovic 2018-02-19 15:29:35 UTC
Oops, the actual and expected results are swapped. Sorry!

Comment 10 Carlos Goncalves 2018-04-06 14:13:22 UTC
FWIW, this bug was verified by upstream CI: https://review.openstack.org/#/c/550431/

Comment 13 errata-xmlrpc 2018-06-27 13:44:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.