Bug 1547569 - FFU: redis pcs resource is not deleted after running upgrade_steps_playbook.yaml
Summary: FFU: redis pcs resource is not deleted after running upgrade_steps_playbook.yaml
Keywords:
Status: CLOSED DUPLICATE of bug 1547570
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: ---
Assignee: Marios Andreou
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-21 14:51 UTC by Marius Cornea
Modified: 2018-03-07 14:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-07 14:57:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Cornea 2018-02-21 14:51:30 UTC
Description of problem:

After running ansible-playbook --module-path /usr/share/ansible-modules/ -i /usr/bin/tripleo-ansible-inventory -b tripleo-yK2HTX-config/upgrade_steps_playbook.yaml --skip-tags=validation

redis pcs resource is not deleted which will collide later during deploy step when the redis container and bundle resource are going to be created

[root@controller-0 heat-admin]# pcs status
Cluster name: tripleo_cluster
Stack: corosync
Current DC: controller-0 (version 1.1.16-12.el7_4.7-94ff4df) - partition with quorum
Last updated: Wed Feb 21 01:28:51 2018
Last change: Wed Feb 21 01:16:01 2018 by hacluster via crmd on controller-0

1 node configured
9 resources configured (8 DISABLED)

Online: [ controller-0 ]

Full list of resources:

ip-172.17.3.17 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.4.16 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.1.15 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-192.168.24.7 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-10.0.0.107 (ocf::heartbeat:IPaddr2): Stopped (disabled)
Clone Set: rabbitmq-clone [rabbitmq]
Stopped (disabled): [ controller-0 ]
Master/Slave Set: redis-master [redis]
Stopped (disabled): [ controller-0 ]
ip-172.17.1.14 (ocf::heartbeat:IPaddr2): Started controller-0
openstack-cinder-volume (systemd:openstack-cinder-volume): Stopped (disabled)

Daemon Status:
corosync: active/enabled
pacemaker: active/enabled
pcsd: active/enabled

Comment 2 Marios Andreou 2018-03-07 14:57:09 UTC
please see comment at https://bugzilla.redhat.com/show_bug.cgi?id=1547570#c3 - lets re-open if we reach a different conclusion thanks

*** This bug has been marked as a duplicate of bug 1547570 ***


Note You need to log in before you can comment on or make changes to this bug.