Bug 1547570 - FFU: rabbitmq pcs resource is not deleted after running upgrade_steps_playbook.yaml
Summary: FFU: rabbitmq pcs resource is not deleted after running upgrade_steps_playboo...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: ---
Assignee: Marios Andreou
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1547569 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-21 14:53 UTC by Marius Cornea
Modified: 2018-03-07 15:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-07 15:23:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 539249 None None None 2018-03-07 14:56:47 UTC
OpenStack gerrit 547476 None None None 2018-03-07 15:03:04 UTC

Description Marius Cornea 2018-02-21 14:53:12 UTC
Description of problem:
After running ansible-playbook --module-path /usr/share/ansible-modules/ -i /usr/bin/tripleo-ansible-inventory -b tripleo-yK2HTX-config/upgrade_steps_playbook.yaml --skip-tags=validation

rabbitmq pcs resource is not deleted which will collide later during deploy step when the rabbitmq container and bundle resource is going to be created

[root@controller-0 heat-admin]# pcs status
Cluster name: tripleo_cluster
Stack: corosync
Current DC: controller-0 (version 1.1.16-12.el7_4.7-94ff4df) - partition with quorum
Last updated: Wed Feb 21 01:28:51 2018
Last change: Wed Feb 21 01:16:01 2018 by hacluster via crmd on controller-0

1 node configured
9 resources configured (8 DISABLED)

Online: [ controller-0 ]

Full list of resources:

ip-172.17.3.17 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.4.16 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.1.15 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-192.168.24.7 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-10.0.0.107 (ocf::heartbeat:IPaddr2): Stopped (disabled)
Clone Set: rabbitmq-clone [rabbitmq]
Stopped (disabled): [ controller-0 ]
Master/Slave Set: redis-master [redis]
Stopped (disabled): [ controller-0 ]
ip-172.17.1.14 (ocf::heartbeat:IPaddr2): Started controller-0
openstack-cinder-volume (systemd:openstack-cinder-volume): Stopped (disabled)

Daemon Status:
corosync: active/enabled
pacemaker: active/enabled
pcsd: active/enabled

Comment 3 Marios Andreou 2018-03-07 14:56:47 UTC
Hi Marius, as you know I picked up this and the seemingly related BZ 1547581 and BZ 1547569 for triage. 

To be clear, this BZ is filed in relation to the FFU workflow but it is specifically about the 12-13 upgrade part. As such note that we recently updated the pacemaker upgrade tasks with https://review.openstack.org/#/c/539249/ ... it should make it that when you start from a non containerized environment (as you would be coming via FFU) this block https://github.com/openstack/tripleo-heat-templates/blob/master/docker/services/pacemaker/rabbitmq.yaml#L264-L268 will/should/could ;) indeed do what you expect and remove the pcs resource.

There still is another revision of those from Damien at https://review.openstack.org/#/c/547476/. Not sure what to do with this and the other two bugzillas. Do you want to use it to track those pacemaker changes - I can add both to trackers. If so we can probably close the other two as duplicate (doing so please move back if you disagree/lets discuss thanks)

Comment 4 Marios Andreou 2018-03-07 14:57:09 UTC
*** Bug 1547569 has been marked as a duplicate of this bug. ***

Comment 5 Marios Andreou 2018-03-07 14:57:28 UTC
*** Bug 1547581 has been marked as a duplicate of this bug. ***

Comment 6 Marius Cornea 2018-03-07 15:23:07 UTC
As we synced on IRC based on my tests with the latest set of FFU patches I can see that the rabbitmq and redis pcs resources get deleted and only the cinder-volume remains created so I'll close this bug and re-open the Cinder one.


Note You need to log in before you can comment on or make changes to this bug.