Bug 1548557 - After upgrade to FC28 gnome shell does not start
Summary: After upgrade to FC28 gnome shell does not start
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-23 20:37 UTC by Mirek Svoboda
Modified: 2019-03-22 21:44 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-03-22 21:44:44 UTC


Attachments (Terms of Use)
journal (937.30 KB, text/x-vhdl)
2018-02-23 20:37 UTC, Mirek Svoboda
no flags Details
output of rpm -qa (61.96 KB, text/plain)
2018-02-23 20:37 UTC, Mirek Svoboda
no flags Details

Description Mirek Svoboda 2018-02-23 20:37:12 UTC
Created attachment 1400034 [details]
journal

Description of problem:
Gnome login dialog does not appear. In journal, it is visible that gnome shell is crashing. The journal is attached.

FC27 up-to-date with updates-testing repo has been upgraded using dnf:
sudo dnf system-upgrade download --releasever=28 --allowerasing
sudo dnf system-upgrade reboot
The upgrade went smoothly, but after reboot there is only blank screen, no login dialog. It is possible to switch to TTY using ctrl+alt+F2.
Selinux has been switched to permissive mode, but that did not help.

Version-Release number of selected component (if applicable):
gnome-shell-3.27.1-5.fc28.x86_64

How reproducible:
It happens during every boot and no workaround has been identified.
Not sure whether 100% reproducible, did not have a chance to try the upgrade on another system.

Steps to Reproduce:
1. Update FC27 to be up to date
2. Upgrade FC27 to FC28
3. Meet with empty screen after reboot

Actual results:
Blank screen after boot.

Expected results:
Gnome login screen.

Additional info:
attached journal and rpm -qa output

Comment 1 Mirek Svoboda 2018-02-23 20:37 UTC
Created attachment 1400035 [details]
output of rpm -qa

Comment 2 Mirek Svoboda 2018-02-23 20:42:40 UTC
Relevant log excerpt:
Feb 23 20:15:48 n51 org.gnome.Shell.desktop[1396]: /usr/bin/gnome-shell: symbol lookup error: /usr/lib64/gnome-shell/libgnome-shell.so: undefined symbol: meta_window_get_flatpak_id
Feb 23 20:15:48 n51 /usr/libexec/gdm-wayland-session[1092]: gnome-session-binary[1170]: DEBUG(+): GsmAutostartApp: (pid:1396) done (status:127)
Feb 23 20:15:48 n51 /usr/libexec/gdm-wayland-session[1092]: gnome-session-binary[1170]: WARNING: App 'org.gnome.Shell.desktop' exited with code 127
Feb 23 20:15:48 n51 /usr/libexec/gdm-wayland-session[1092]: gnome-session-binary[1170]: DEBUG(+): GsmManager: disposing manager
Feb 23 20:15:48 n51 gnome-session-binary[1170]: Unrecoverable failure in required component org.gnome.Shell.desktop
Feb 23 20:15:48 n51 gnome-session-binary[1170]: DEBUG(+): GsmAutostartApp: (pid:1396) done (status:127)

The journal has been captured with debug enabled at /etc/gdm/custom.conf

Comment 3 Laurent Wandrebeck 2018-02-24 13:11:24 UTC
Confirmed here. It seems linked to https://github.com/GNOME/mutter/commit/ab5ac21104fb191a30c9c78fee5bd28e1f4cf06f .
I would bet on a mismatch between gnome packages versions in F28. I’ve seen that there are still some 3.26 packages during update, whereas some other are 3.27.x.

HTH.

Comment 4 Couret Charles-Antoine 2018-02-24 15:24:13 UTC
Same issue for me.

Comment 5 Mirek Svoboda 2018-02-24 19:48:51 UTC
Live ISO Fedora-Workstation-Live-x86_64-28-20180221.n.0.iso also suffers from this issue.

Comment 6 Branko Grubić 2018-02-25 12:37:03 UTC
Adding myself to CC.
For me latest gnome-shell from koji ( https://koji.fedoraproject.org/koji/buildinfo?buildID=1048592 ) works gnome-shell-3.27.91-2.fc28

Comment 7 Laurent Wandrebeck 2018-02-25 17:19:52 UTC
Indeed, now everything is fine with latest gnome-shell.
The point now is mouse cursor is moving fine, but clicks have no effect at all.

Comment 8 Laurent Wandrebeck 2018-02-25 17:44:09 UTC
original mouse is ps2, tested with an usb one, same symptoms, right, left, middle click does not do anything. scroll whell does not work either.
Things were fine in F27 (mouse configured as left handed). Anyone having the same problem ? Should I open another bug ?

Comment 9 Couret Charles-Antoine 2018-02-25 17:48:24 UTC
The mouse issue is already known: https://bugzilla.redhat.com/show_bug.cgi?id=1547691

Comment 10 Laurent Wandrebeck 2018-02-25 18:10:54 UTC
sorry for the noise, did not search, navigation is a bit painful with a keyboard only :) thx for the pointer !

Comment 11 Mirek Svoboda 2018-03-03 09:25:26 UTC
I confirm that this issue is fixed in Fedora-Workstation-Live-x86_64-28-20180301.n.0.iso

Comment 12 Ed 2018-06-23 19:16:21 UTC
(In reply to Mirek Svoboda from comment #11)
> I confirm that this issue is fixed in
> Fedora-Workstation-Live-x86_64-28-20180301.n.0.iso

I am presently experiencing the same issue and it is June 23, 2018 after upgrading from Fedora 27 to Fedora 28 desktop on Dell Inspiron E1505 32bit laptop.

I tried the following:

Booted into single user mode
Looked at the journalctl file and noticed the following

NX(Execute Disable) protection cannot be enabled: non-PAE kernel random: fast init done
systemd-modules failed to find module "vxboxdrv; vboxnetflt; vboxnetadp; vboxpci
failed to start switch root
failed to start load kernel modules

tried

mount -o remount,rw/systroot
rm -rf /sysroot/etc/os-release
cp /usr/lib/os-release /sysroot/etc
exit
hard reboot

Now it hangs at:

Started Gnome display manager. dispatcher service . . . . ges.e.ansactions. . .

Comment 13 Michael Adam 2018-09-01 12:09:43 UTC
I recently ugraded one of my machines from F27 --> F28.
The machine is a thinkpad W541.

The system seems to be suffering from the same problem.

For an existing user, Gnome does not even start at all (even after removing all things in $HOME/.config and $HOME/.local I could spot, but no success. I see several crashes, Errors and "Unrecoverable failure" messages for gnome-shell in the journal.

For a new user i created as a test, Gnome starts up, but I still see stack traces and errors in the log (not the "Unrecoverable failure though"). But the gnome session does not work fully, for instance the gnome terminal does not come up. I start it, see a spinning wheel for a few seconds, and then nothing.

So for me, this bug is not fixed.

==> hope it is correct to reopen the bug.

Pleas let me know if this is not correct.

Comment 14 Mirek Svoboda 2019-03-22 21:44:44 UTC
@Michael Adam
As I cannot see any logs attached nor package versions, it is hard to tell whether your report relates to the same bug which I reported.
I believe the bug I have originally reported is successfully solved, therefore closing this bug report again.


Note You need to log in before you can comment on or make changes to this bug.