Bug 1549577 - [TRACKER] Add support in virtio-win drivers for VIRTIO_F_IOMMU_PLATFORM virtio feature
Summary: [TRACKER] Add support in virtio-win drivers for VIRTIO_F_IOMMU_PLATFORM virti...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.0
Hardware: Unspecified
OS: Windows
medium
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: lijin
URL:
Whiteboard:
Depends On: 1530210 1539256 1549587 1549595 1549596 1549597 1549602 1682882
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-27 12:56 UTC by Yan Vugenfirer
Modified: 2020-04-28 16:06 UTC (History)
6 users (show)

Fixed In Version: virtio-win-prewhql-0.1-174
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:15 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:06:07 UTC

Description Yan Vugenfirer 2018-02-27 12:56:05 UTC
Description of problem:
virtio-win drivers are not reporting VIRTIO_F_IOMMU_PLATFORM feature.

There are several things that should be done to fix it:

1. Ensure that Windows drivers are using Windows kernel DMA (easier for storage and network drivers that are already using framework specific APIs, additional work should be done for WDF based drivers).

2. Report the feature.

Additional BZs will be opened for each of the drivers.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Yan Vugenfirer 2019-12-11 13:03:11 UTC
Changes are in: https://github.com/virtio-win/kvm-guest-drivers-windows/pull/418

Comment 9 lijin 2019-12-26 09:25:20 UTC
Change status to verified as all dependency bugs are verified

Comment 15 errata-xmlrpc 2020-04-28 16:05:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.