Bug 1549602 - Add support in virtio-input Windows driver for VIRTIO_F_IOMMU_PLATFORM virtio feature
Summary: Add support in virtio-input Windows driver for VIRTIO_F_IOMMU_PLATFORM virtio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.0
Hardware: Unspecified
OS: Windows
low
low
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Peixiu Hou
URL:
Whiteboard:
Depends On: 1682882
Blocks: 1558351 1549577
TreeView+ depends on / blocked
 
Reported: 2018-02-27 13:34 UTC by Yan Vugenfirer
Modified: 2020-04-28 16:06 UTC (History)
7 users (show)

Fixed In Version: virtio-win-prewhql-0.1-174
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:15 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:06:07 UTC

Description Yan Vugenfirer 2018-02-27 13:34:28 UTC
Description of problem:
virtio-win drivers are not reporting VIRTIO_F_IOMMU_PLATFORM feature.

There are several things that should be done to fix it:

1. Ensure that Windows drivers are using Windows kernel DMA (easier for storage and network drivers that are already using framework specific APIs, additional work should be done for WDF based drivers).

2. Report the feature.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Yan Vugenfirer 2019-12-11 12:58:50 UTC
Changes are in: https://github.com/virtio-win/kvm-guest-drivers-windows/pull/418

Comment 7 Peixiu Hou 2019-12-16 02:55:22 UTC
Reproduced this issue with build virtio-win-prewhql-173 on win10-32 guest cm, cannot install vioinput driver with iommu_platform=on.

Verified this issue with build virtio-win-prewhql-174 on win10-32 guest vm, virtio-input driver can be installed successfully with iommu_platform=on and works normally.

So this bug is fixed, changed the bug status to verified.

Comment 13 errata-xmlrpc 2020-04-28 16:05:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757


Note You need to log in before you can comment on or make changes to this bug.