Bug 1549644 (CVE-2017-18198) - CVE-2017-18198 libcdio: Heap-based buffer over-read in print_iso9660_recurse function in iso-info.c
Summary: CVE-2017-18198 libcdio: Heap-based buffer over-read in print_iso9660_recurse ...
Status: NEW
Alias: CVE-2017-18198
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20180227,reported=2...
Keywords: Security
Depends On: 1553770 1549712 1549713 1553769
Blocks: 1549715
TreeView+ depends on / blocked
 
Reported: 2018-02-27 14:56 UTC by Pedro Sampaio
Modified: 2019-05-01 21:55 UTC (History)
3 users (show)

(edit)
A heap corruption bug was found in the way libcdio handled processing of ISO files. An attacker could potentially use this flaw to crash applications using libcdio by tricking them into processing crafted ISO files, thus resulting in local DoS.
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3246 None None None 2018-10-30 07:52 UTC

Description Pedro Sampaio 2018-02-27 14:56:10 UTC
A heap corruption bug was found in the way libcdio handled processing of ISO files. An attacker could potentially use this flaw to crash applications using libcdio by tricking them into processing crafted ISO files, thus resulting in local DoS.

Upstream issue:

https://savannah.gnu.org/bugs/?52265

Upstream release:

http://ftp.gnu.org/gnu/libcdio/libcdio-1.0.0.tar.gz

Comment 1 Pedro Sampaio 2018-02-27 17:08:34 UTC
Created libcdio tracking bugs for this issue:

Affects: fedora-all [bug 1549713]

Comment 7 errata-xmlrpc 2018-10-30 07:52:53 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2018:3246 https://access.redhat.com/errata/RHSA-2018:3246


Note You need to log in before you can comment on or make changes to this bug.