Bug 1550405 - Extra buttons on Container Provider page
Summary: Extra buttons on Container Provider page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Moti Asayag
QA Contact: Vatsal Parekh
URL:
Whiteboard:
: 1637854 (view as bug list)
Depends On:
Blocks: 1646613
TreeView+ depends on / blocked
 
Reported: 2018-03-01 08:23 UTC by Vatsal Parekh
Modified: 2019-02-11 14:09 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1646613 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:09:37 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Vatsal Parekh 2018-03-01 08:23:15 UTC
Description of problem:
Upstream issue: https://github.com/ManageIQ/manageiq-ui-classic/issues/3498

In the Add provider or edit provider, there are 2 extra buttons (shown in the upstream issue, same in the downstream as well)

Version-Release number of selected component (if applicable):
Version 5.9.0.22.20180221205805_f93a675

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 CFME Bot 2018-03-13 08:17:18 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:

https://github.com/ManageIQ/manageiq-ui-classic/commit/486e30ac49d8796d010c718b0a5a44688cda46c7
commit 486e30ac49d8796d010c718b0a5a44688cda46c7
Author:     Moti Asayag <masayag@redhat.com>
AuthorDate: Thu Jan 18 09:15:11 2018 -0500
Commit:     Moti Asayag <masayag@redhat.com>
CommitDate: Thu Jan 18 09:15:11 2018 -0500

    Hide disabled tabs

    The metrics & alerts tabs where partially visible.
    Those tabs become more visible if the virtualization manager is
    selected.

    This PR hides any of the tabs if aren't used in Add/Edit provider.

    Closes https://github.com/ManageIQ/manageiq-ui-classic/issues/3498
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1550405

 app/assets/javascripts/controllers/ems_common/ems_common_form_controller.js | 20 +-
 app/views/layouts/angular/_multi_auth_credentials.html.haml | 10 +-
 2 files changed, 24 insertions(+), 6 deletions(-)

Comment 4 Vatsal Parekh 2018-10-01 10:44:25 UTC
Seems working on 5.10.0.17

Comment 6 CFME Bot 2018-11-05 18:51:31 UTC
New commit detected on ManageIQ/manageiq-ui-classic/gaprindashvili:

https://github.com/ManageIQ/manageiq-ui-classic/commit/55234a8197ea38156b9b2c5b58a85c4d4ec970ac
commit 55234a8197ea38156b9b2c5b58a85c4d4ec970ac
Author:     Moti Asayag <masayag@redhat.com>
AuthorDate: Thu Jan 18 09:15:11 2018 -0500
Commit:     Moti Asayag <masayag@redhat.com>
CommitDate: Thu Jan 18 09:15:11 2018 -0500

    Hide disabled tabs

    The metrics & alerts tabs where partially visible.

    This PR hides any of the tabs if aren't used in Add/Edit provider.

    Closes https://github.com/ManageIQ/manageiq-ui-classic/issues/3498
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1550405

 app/assets/javascripts/controllers/ems_common/ems_common_form_controller.js | 16 +-
 app/views/layouts/angular/_multi_auth_credentials.html.haml | 10 +-
 2 files changed, 20 insertions(+), 6 deletions(-)

Comment 7 Satoe Imaishi 2018-11-05 18:52:36 UTC
*** Bug 1637854 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.