Bug 1551543 - Upgrade fails due to incorrect version checking
Summary: Upgrade fails due to incorrect version checking
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 26
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
Whiteboard: https://fedoraproject.org/wiki/Common...
: 1552547 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2018-03-05 12:02 UTC by Mark Stanton
Modified: 2018-04-15 18:12 UTC (History)
17 users (show)

Fixed In Version: rpm-4.13.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-04-15 18:12:04 UTC
Type: Bug

Attachments (Terms of Use)
Failures listed by transaction check (2.51 KB, text/plain)
2018-03-05 12:02 UTC, Mark Stanton
no flags Details
dnf log, part one (9.41 MB, text/plain)
2018-03-06 15:17 UTC, Mark Stanton
no flags Details

Description Mark Stanton 2018-03-05 12:02:29 UTC
Created attachment 1404297 [details]
Failures listed by transaction check

Description of problem:
Running system upgrade from F26 to f27 using the command

dnf system-upgrade download --releasever=27 --allowerasing

fails with the 19 version comparison failures listed in the attached file.

How reproducible: 

Happens every time. Tried maybe a dozen times after running simple fixes listed in dnf output and on the page fedoraproject.org/wiki/DNF_system_upgrade

Steps to Reproduce:
1. Upgrade F26 to latest versions
2. Run the dnf command above

Actual results:

After downloading the files, the transaction check (vs depsolve) gives the errors listed in the attached file upgradeFails.txt . They are all php-composer linked. I don't have this installed on my F26 system.

Expected results:

Finishing the process allowing me to proceed to upgrade reboot. I have tried this, it refuses complaining that the system is not in a suitable state to do this.

Additional info:

I have checked the latest F27 filestore for the first indicated failure 

(php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2) is needed by composer-1.6.3-1.fc27.noarch

and it shows that the version there is 1.0.7 which is >= to 1.0 and so this seems to me to be a bug. I have not checked the other package versions.

I don't have composer installed on my F26 system so it seems to me that this cannot be an error referencing my system at all.

I have removed all 3rd party repos and tried again, the process still fails.

It was suggested it may be linked to my having a webserver installed, I've removed it and tried again, the problem persists.

Sysinfo at


I don't know how long until this expires so I also have a copy if required.

Comment 1 Marek Blaha 2018-03-06 13:38:55 UTC
Please, can you provide /var/log/dnf.log file?

Comment 2 Mark Stanton 2018-03-06 14:01:05 UTC
(In reply to Marek Blaha from comment #1)
> Please, can you provide /var/log/dnf.log file?

Yes. I haven't been able to find a way of attaching it here, so I've put it up as a paste, the link is


It's rather large, but claims it's uploaded. I'm trying to view it to check now, but it's taking a very long time to display, so I'll leave it for you to see.

If it's not worked, let me know how I can get the file to you.

Comment 3 Mark Stanton 2018-03-06 14:04:29 UTC
I should say, the upgrade attempt was first actioned yesterday, 5th March.

Comment 4 Marek Blaha 2018-03-06 14:40:50 UTC
There should be Attachments block with link to add a new one just above the comments.
Or try this link:

I'm sorry, but I'm not able to download it from paste.fedoraproject.org.

Comment 5 Mark Stanton 2018-03-06 15:17:40 UTC
Created attachment 1404887 [details]
dnf log, part one

I think this covers the situation properly.

I have multiple subsequent attempts, making the file 21Mb, too big to upload in one go.

Let me know if you want the other half.

Comment 6 Marek Blaha 2018-03-07 08:04:28 UTC
Hi, your uploaded log is good enough, no need of the other half.

I can reproduce this problem when package php-pdepend-PHP-Depend is installed on F26. Attempt to upgrade to F27 then fails with error very similar to yours (not exactly the same, I've got only first 7 of your error messages, so there probably is another problematic package).

So this is reproducer of problem:
1. install and upgrade F26
2. dnf install php-pdepend-PHP-Depend
3. dnf system-upgrade download --releasever=27

As a workaround, I can suggest uninstalling php-pdepend-PHP-Depend (and probably other packages, phpMyAdmin is one of suspects) and try to upgrade. Another workaround can be installing newer rpm (4.14) on your F26 machine.

I switch this bug to rpm and kindly ask them for help with these questions:

1. there is change in dependencies for package php-pdepend-PHP-Depend between
php-composer(composer/ca-bundle) < 2
php-composer(composer/ca-bundle) >= 1.0

and F27:
(php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)

Is this rich dependency right and working?

2. Is this (with) rich dependency fully supported on F26 (because transaction is checked by F26 rpm)? Documentation says that with operator works from rpm 4.14, but F26 contains 4.13.

Comment 7 Mark Stanton 2018-03-07 09:26:31 UTC
Many thanks for this.  While waiting I will try removing the "depend" package and report back.

I have previously tried after removing phpMyAdmin without success (log in the second half ;) ), but perhaps it matters in combination with the "depend" package.

Comment 8 Marek Blaha 2018-03-07 09:30:07 UTC
Hi Mark,
there is another workaround you can try, without uninstalling any of your packages.

On F26:
# dnf system-upgrade download --releasever=27 --disablerepo=updates --no-downgrade
# dnf system-upgrade reboot

And then after F27 boots:
# dnf upgrade rpm
# dnf upgrade dnf
# dnf distrosync

Comment 9 Igor Gnatenko 2018-03-07 09:54:11 UTC
DNF should always use target RPM to perform the upgrade. Nothing to do from RPM side.

Comment 10 Igor Gnatenko 2018-03-07 10:47:18 UTC
*** Bug 1552547 has been marked as a duplicate of this bug. ***

Comment 11 Panu Matilainen 2018-03-07 10:52:13 UTC
Yeah, although the flaw on rpm-side is that these later additions to rich deps are not separately tracked with new rpmlib() dependencies. Preciously little that can be done about it after the fact though.

Comment 12 Igor Gnatenko 2018-03-07 10:56:20 UTC
(In reply to Panu Matilainen from comment #11)
> Yeah, although the flaw on rpm-side is that these later additions to rich
> deps are not separately tracked with new rpmlib() dependencies. Preciously
> little that can be done about it after the fact though.

This would definitely give better error messages, but won't help with upgrades. I think owner of this bugreport wants transaction to succeed instead of getting better error message ;)

Comment 13 Tom Chiverton 2018-03-17 16:37:43 UTC
F25 to F27 upgrades also broken (gives error related to php-composer too).

Same work around from #8 works.

Comment 14 Tom Chiverton 2018-03-17 17:52:22 UTC
Correction needed --allowerase too

Comment 15 Panu Matilainen 2018-03-28 12:37:25 UTC
It was decided this particular upgrade case will be fixed by backporting the missing rich dependencies to rpm 4.13.x, reassigning and changing version to f26.

Comment 16 Fedora Update System 2018-03-28 14:14:04 UTC
rpm-4.13.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d4cacdf9bc

Comment 17 Fedora Update System 2018-03-29 00:19:14 UTC
rpm-4.13.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d4cacdf9bc

Comment 18 Fedora Update System 2018-04-15 18:12:04 UTC
rpm-4.13.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.