Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1552547 - Broken system upgrade due to rich deps
Broken system upgrade due to rich deps
Status: CLOSED DUPLICATE of bug 1551543
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-07 05:17 EST by Jaroslav Mracek
Modified: 2018-04-03 11:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-07 05:47:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Mracek 2018-03-07 05:17:50 EST
Description of problem:
If any of packages from list bellow is in system-upgrade transaction, system upgrade fails due to missing support of rich deps presented in Fedora 27 by RPM in Fedora 26. Rich deps using "with" statement is not supported by RPM in Fedora 26, but the system-upgrade transaction with F27 packages has to be checked and performed by F26 RPM.

Packages in Fedora 27 with rich dep using "with" statement:
composer
php-cs-fixer
php-phpunit-PHPUnit
php-phpunit-dbunit3
php-phpunit-mock-objects5
php-sebastian-comparator2
phpMyAdmin
phpcov
phpunit6
rust-aho-corasick-devel
rust-atty-devel
rust-bincode0.8-devel
rust-cc-devel
rust-chan-devel
rust-clap-devel
rust-cmake-devel
rust-coco-devel
rust-curl-sys-devel
rust-datetime-devel
rust-docopt-devel
rust-either-devel
rust-encoding-devel
rust-encoding_rs-devel
rust-env_logger-devel
rust-exa-devel
rust-git2-devel
rust-globset-devel
rust-grep-devel
rust-handlebars-devel
rust-idna-devel
rust-ignore-devel
rust-iso8601-devel
rust-itertools-devel
rust-lazy_static-devel
rust-libgit2-sys-devel
rust-libssh2-sys-devel
rust-libz-sys-devel
rust-linked-hash-map-devel
rust-lipsum-devel
rust-locale-devel
rust-log-devel
rust-log0.3-devel
rust-memchr-devel
rust-memmap-devel
rust-nom-devel
rust-num_cpus-devel
rust-number_prefix-devel
rust-openssl-sys-devel
rust-pad-devel
rust-pulldown-cmark-devel
rust-quickcheck-devel
rust-rand-devel
rust-rayon-core-devel
rust-rayon-devel
rust-regex-devel
rust-rustc-test-devel
rust-rustc_version-devel
rust-semver-devel
rust-serde-devel
rust-serde_bytes-devel
rust-serde_cbor-devel
rust-serde_derive-devel
rust-serde_derive_internals-devel
rust-serde_json-devel
rust-serde_json0.8-devel
rust-serde_test-devel
rust-serde_yaml-devel
rust-syn-devel
rust-synom-devel
rust-tempdir-devel
rust-term_grid-devel
rust-term_size-devel
rust-textwrap-devel
rust-thread_local-devel
rust-threadpool-devel
rust-time-devel
rust-tokei-devel
rust-toml-devel
rust-unicode-bidi-devel
rust-unreachable-devel
rust-url-devel
rust-users-devel
rust-vec_map-devel
rust-version-sync-devel
rust-walkdir-devel
rust-yaml-rust-devel
rust-yaml-rust0.3-devel
rust-zoneinfo_compiled-devel
Comment 1 Jaroslav Mracek 2018-03-07 05:35:26 EST
In Fedora 28 the list of packages with rich deps using "with" statement:
carto
composer
elasticdump
jake
jasmine-node
kosmtik
nodejs-JSV
nodejs-accepts
nodejs-agent-base
nodejs-agentkeepalive
nodejs-archiver
nodejs-argparse
nodejs-bl
nodejs-buffertools
nodejs-caller-callsite
nodejs-caller-path
nodejs-chai
nodejs-chainsaw
nodejs-chalk
nodejs-clean-css
nodejs-cmd-shim
nodejs-compression
nodejs-concat-stream
nodejs-config-chain
nodejs-connect
nodejs-create-error-class
nodejs-cross-spawn
nodejs-css-select
nodejs-css-stringify
nodejs-csscomb-core
nodejs-debug
nodejs-deep-eql
nodejs-defence
nodejs-define-properties
nodejs-degenerator
nodejs-detective
nodejs-dezalgo
nodejs-difflet
nodejs-dtree
nodejs-duplexify
nodejs-ecstatic
nodejs-end-of-stream
nodejs-es-abstract
nodejs-es-to-primitive
nodejs-escodegen
nodejs-event-stream
nodejs-express
nodejs-express-session
nodejs-fg-lodash
nodejs-figures
nodejs-filelist
nodejs-fill-keys
nodejs-findup-sync
nodejs-follow
nodejs-form-data
nodejs-from2
nodejs-fs-extra
nodejs-fs-vacuum
nodejs-fs-write-stream-atomic
nodejs-fstream
nodejs-fstream-ignore
nodejs-fstream-npm
nodejs-glob
nodejs-globule
nodejs-grunt
nodejs-grunt-cli
nodejs-grunt-contrib-clean
nodejs-grunt-contrib-concat
nodejs-grunt-contrib-connect
nodejs-grunt-contrib-csslint
nodejs-grunt-contrib-cssmin
nodejs-grunt-contrib-htmlmin
nodejs-grunt-contrib-internal
nodejs-grunt-contrib-less
nodejs-grunt-contrib-uglify
nodejs-grunt-contrib-watch
nodejs-grunt-init
nodejs-grunt-legacy-log
nodejs-grunt-legacy-log-utils
nodejs-grunt-legacy-util
nodejs-grunt-saucelabs
nodejs-gzip-size
nodejs-handlebars
nodejs-har-validator
nodejs-has
nodejs-hawk
nodejs-http-errors
nodejs-http-proxy
nodejs-http-server
nodejs-humanize-ms
nodejs-i18n-transform
nodejs-i2c
nodejs-inherit
nodejs-init-package-json
nodejs-into-stream
nodejs-is-equal
nodejs-is-regex
nodejs-istanbul
nodejs-jade
nodejs-js-yaml
nodejs-kind-of
nodejs-klaw
nodejs-lazystream
nodejs-less
nodejs-load-grunt-tasks
nodejs-log-symbols
nodejs-mapnik-pool
nodejs-mapnik-reference
nodejs-markdown
nodejs-maxmin
nodejs-millstone
nodejs-minimatch
nodejs-minstache
nodejs-mkdirp
nodejs-mkfiletree
nodejs-morgan
nodejs-muffin
nodejs-multimatch
nodejs-mz
nodejs-node-expat
nodejs-node-stringprep
nodejs-nomnom
nodejs-nopt
nodejs-npm-package-arg
nodejs-npm-stats
nodejs-npmlog
nodejs-nsp-api
nodejs-nsp-audit-shrinkwrap
nodejs-object-dot-entries
nodejs-osenv
nodejs-pac-resolver
nodejs-package-info
nodejs-parse-json
nodejs-passport
nodejs-passport-oauth
nodejs-passport-oauth1
nodejs-passport-oauth2
nodejs-pause-stream
nodejs-pem
nodejs-pg-types
nodejs-pgpass
nodejs-pinkie-promise
nodejs-portfinder
nodejs-portscanner
nodejs-postgres-interval
nodejs-progress-stream
nodejs-promise
nodejs-prompt
nodejs-promzard
nodejs-proxy
nodejs-proxyquire
nodejs-q-io
nodejs-rc
nodejs-read
nodejs-read-all-stream
nodejs-read-cmd-shim
nodejs-read-installed
nodejs-read-package-json
nodejs-readdir-scoped-modules
nodejs-readdirp
nodejs-recast
nodejs-registry-url
nodejs-request
nodejs-resumer
nodejs-sauce-tunnel
nodejs-send
nodejs-seq
nodejs-sha
nodejs-silent-npm-registry-client
nodejs-simple-assert
nodejs-single-line-log
nodejs-split
nodejs-srs
nodejs-std-mocks
nodejs-stream-combiner
nodejs-stream-equal
nodejs-stream-reduce
nodejs-stream-spigot
nodejs-string-width
nodejs-strip-ansi
nodejs-stylus
nodejs-superagent
nodejs-tape
nodejs-tar
nodejs-temp
nodejs-thenify
nodejs-through2
nodejs-tilejson
nodejs-tilelive
nodejs-tilelive-mapnik
nodejs-tiny-lr-fork
nodejs-tough-cookie
nodejs-ttembed-js
nodejs-unicode-length
nodejs-utile
nodejs-verror
nodejs-vow-fs
nodejs-which
nodejs-winston
nodejs-write-file-atomic
nodejs-ws
nodejs-xml2js
nodejs-zip-stream
php-bartlett-PHP-CompatInfo
php-consolidation-output-formatters
php-cs-fixer
php-phpspec-prophecy
php-phpunit-FinderFacade
php-phpunit-PHP-Invoker
php-phpunit-PHPUnit
php-phpunit-PHPUnit-MockObject
php-phpunit-PHPUnit-Selenium
php-phpunit-comparator
php-phpunit-dbunit3
php-phpunit-dbunit4
php-phpunit-exporter
php-phpunit-mock-objects5
php-phpunit-mock-objects6
php-phpunit-php-code-coverage6
php-phpunit-phploc
php-sebastian-comparator2
php-sebastian-exporter3
php-sebastian-object-enumerator
php-sebastian-object-enumerator3
php-zendframework-zend-session
phpMyAdmin
phpcov
phpcpd
phpunit6
phpunit7
python2-ipdb
rubygem-pdf-inspector
rubygem-pdf-reader
rubygem-prawn
rubygem-prawn-table
rust-aho-corasick-devel
rust-arrayvec-devel
rust-atk-sys-devel
rust-atty-devel
rust-backtrace-devel
rust-backtrace-sys-devel
rust-base64-devel
rust-bincode-devel
rust-bincode0.8-devel
rust-brev-devel
rust-bytes-devel
rust-cairo-rs-devel
rust-cairo-sys-rs-devel
rust-cbindgen-devel
rust-cc-devel
rust-chan-devel
rust-chrono-devel
rust-clap-devel
rust-cmake-devel
rust-coco-devel
rust-cpp_demangle-devel
rust-crc-devel
rust-crossbeam-deque-devel
rust-crossbeam-epoch-devel
rust-crossbeam-utils-devel
rust-crypto-hash-devel
rust-cryptovec-devel
rust-cssparser-devel
rust-cssparser-macros-devel
rust-ctrlc-devel
rust-curl-devel
rust-curl-sys-devel
rust-datetime-devel
rust-dbus-devel
rust-devicemapper-devel
rust-docopt-devel
rust-dtoa-short-devel
rust-either-devel
rust-encoding-devel
rust-encoding_rs-devel
rust-enum_primitive-devel
rust-env_logger-devel
rust-env_logger0.4-devel
rust-errno-devel
rust-error-chain-devel
rust-exa-devel
rust-extprim-devel
rust-extprim_literals_macros-devel
rust-failure-devel
rust-failure_derive-devel
rust-filetime-devel
rust-flame-devel
rust-flate2-devel
rust-float-cmp-devel
rust-foreign-types-devel
rust-fs2-devel
rust-futures-cpupool-devel
rust-gdk-devel
rust-gdk-pixbuf-devel
rust-gdk-pixbuf-sys-devel
rust-gdk-sys-devel
rust-gimli-devel
rust-gio-devel
rust-gio-sys-devel
rust-git2-devel
rust-glib-devel
rust-glib-sys-devel
rust-globset-devel
rust-gobject-sys-devel
rust-goblin-devel
rust-grep-devel
rust-gtk-devel
rust-gtk-rs-lgpl-docs-devel
rust-gtk-source-sys-devel
rust-gtk-sys-devel
rust-gzip-header-devel
rust-hamcrest-devel
rust-handlebars-devel
rust-humantime-devel
rust-idna-devel
rust-ignore-devel
rust-intervaltree-devel
rust-iovec-devel
rust-iso8601-devel
rust-itertools-devel
rust-jobserver-devel
rust-lazy_static-devel
rust-libdbus-sys-devel
rust-libgit2-sys-devel
rust-libloading-devel
rust-libssh2-sys-devel
rust-libudev-devel
rust-libudev-sys-devel
rust-libz-sys-devel
rust-linked-hash-map-devel
rust-lipsum-devel
rust-locale-devel
rust-log-devel
rust-log0.3-devel
rust-loopdev-devel
rust-lzma-sys-devel
rust-memchr-devel
rust-memmap-devel
rust-metadeps-devel
rust-mime-devel
rust-miniz-sys-devel
rust-miniz_oxide-devel
rust-miniz_oxide_c_api-devel
rust-mio-devel
rust-mio-uds-devel
rust-mnt-devel
rust-multimap-devel
rust-net2-devel
rust-newtype_derive-devel
rust-nix-devel
rust-nom-devel
rust-num-bigint-devel
rust-num-complex-devel
rust-num-devel
rust-num-integer-devel
rust-num-iter-devel
rust-num-rational-devel
rust-num-traits0.1-devel
rust-num_cpus-devel
rust-number_prefix-devel
rust-object-devel
rust-openssl-devel
rust-openssl-sys-devel
rust-ordermap-devel
rust-owning_ref-devel
rust-pad-devel
rust-pager-devel
rust-pango-devel
rust-pango-sys-devel
rust-pest_derive-devel
rust-phf_generator-devel
rust-phf_shared-devel
rust-pretty_env_logger-devel
rust-proc-macro2-devel
rust-pulldown-cmark-devel
rust-quickcheck-devel
rust-quickcheck0.4-devel
rust-quickersort-devel
rust-rand-devel
rust-rayon-core-devel
rust-rayon-devel
rust-regex-devel
rust-relay-devel
rust-rustc-test-devel
rust-rustc_version-devel
rust-rustfmt-devel
rust-scroll-devel
rust-scroll_derive-devel
rust-semver-devel
rust-serde-devel
rust-serde_bytes-devel
rust-serde_cbor-devel
rust-serde_derive-devel
rust-serde_derive_internals-devel
rust-serde_ignored-devel
rust-serde_json-devel
rust-serde_json0.8-devel
rust-serde_test-devel
rust-serde_urlencoded-devel
rust-serde_yaml-devel
rust-smallvec-devel
rust-socket2-devel
rust-sourceview-devel
rust-streaming-stats-devel
rust-strings-devel
rust-structopt-derive-devel
rust-structopt-devel
rust-syn-devel
rust-synom-devel
rust-synstructure-devel
rust-syntex_errors-devel
rust-syntex_pos-devel
rust-syntex_syntax-devel
rust-sys-info-devel
rust-tabwriter-devel
rust-tar-devel
rust-tempdir-devel
rust-tempfile-devel
rust-term_grid-devel
rust-term_size-devel
rust-termion-devel
rust-test-assembler-devel
rust-textwrap-devel
rust-thread-id-devel
rust-thread_local-devel
rust-threadpool-devel
rust-time-devel
rust-tokei-devel
rust-tokio-core-devel
rust-tokio-io-devel
rust-tokio-process-devel
rust-tokio-proto-devel
rust-tokio-service-devel
rust-tokio-signal-devel
rust-toml-devel
rust-unicase-devel
rust-unicode-bidi-devel
rust-unreachable-devel
rust-unsafe-any-devel
rust-url-devel
rust-users-devel
rust-uuid-devel
rust-vec_map-devel
rust-version-sync-devel
rust-wait-timeout-devel
rust-walkdir-devel
rust-which-devel
rust-xattr-devel
rust-xz2-devel
rust-yaml-rust-devel
rust-yaml-rust0.3-devel
rust-yubibomb-devel
rust-zoneinfo_compiled-devel
uglify-js
Comment 2 Igor Gnatenko 2018-03-07 05:47:18 EST
Essentially this is duplicate. And there is nothing to do from RPM side, DNF should use RPM from F28 to perform upgrade. This is not only about new rich dependencies, but also about other incompatible changes which lead to segfault instead of proper message (see RPM 4.14 release notes).

*** This bug has been marked as a duplicate of bug 1551543 ***
Comment 3 Kamil Páral 2018-04-03 11:04:00 EDT
This really needs to get documented :-)

Note You need to log in before you can comment on or make changes to this bug.