Bug 15519 - i810 audio works, but is flaky
Summary: i810 audio works, but is flaky
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
: 14935 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 21:14 UTC by Bill Nottingham
Modified: 2014-03-17 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:52:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Default mixer settings that are slightly louder (167 bytes, text/plain)
2000-08-16 22:04 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2000-08-05 21:14:58 UTC
Two main problems (this is against the -19 kernel)

1: drain_dac, dma timeout messages appear often
2: when using sox on an 8-bit mono sound, it doesn't appear
   to be communicating right the lack of mono support:

sox sample.au -t ossdsp /dev/dsp
   produces a really high pitched sound

sox sample.au -t ossdsp -c2 /dev/dsp (to force stereo)
   produces correct output.

Comment 1 Glen Foster 2000-08-07 17:36:49 UTC
This defect is considered MUST-FIX for Winston Gold-release

Comment 2 Alan Cox 2000-08-08 00:35:06 UTC
New driver sent to the list.


Comment 3 Preston Brown 2000-08-15 15:22:25 UTC

*** This bug has been marked as a duplicate of 13671 ***

Comment 4 Rogelio Noriega 2000-08-16 16:43:29 UTC
(RC1) The GX150 i815 chipset. Wav plays, CD plays and MMap plays. However the 
sound is low. Wav. Files are cut off when played complete wav. Does not play.   
It gets better Is there a way the default sound volume setting for this device 
be set higher?

Comment 5 Alan Cox 2000-08-16 16:47:52 UTC
The default is set fairly low because some boards are _very_loud_ when you set
it higher by default. If the board at top volume is a lot quieter than in
windows then I need to know how the external amplifier is wired to the codecs as
this might by a crystal setup with an external amplifier that is connected to
the AC97 GPIO/EAMP pins


Comment 6 Bill Nottingham 2000-08-16 19:41:51 UTC
*** Bug 14935 has been marked as a duplicate of this bug. ***

Comment 7 Alan Cox 2000-08-16 19:43:57 UTC
The standard kernel works, the RH one doesnt. Looks like a patch has gone astray
or something here guys ?


Comment 8 Bill Nottingham 2000-08-16 22:04:09 UTC
If Dell wants a different default volume, you can always
ship an /etc/.aumixrc like the attached file.

Comment 9 Bill Nottingham 2000-08-16 22:04:42 UTC
Created attachment 2579 [details]
Default mixer settings that are slightly louder


Note You need to log in before you can comment on or make changes to this bug.