Bug 15523 - Mgetty crashes on startup
Mgetty crashes on startup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 15212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-05 17:57 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-06 12:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-08-05 17:57:34 EDT
mgetty crashes on startup

gdb /sbin/mgetty 
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) run
Starting program: /sbin/mgetty 

Program received signal SIGSEGV, Segmentation fault.
0x400709d3 in _IO_vfprintf (s=0x0, format=0x8054def "\n--", ap=0xbfffe968)
    at vfprintf.c:271
271	vfprintf.c: No such file or directory.
(gdb) bt
#0  0x400709d3 in _IO_vfprintf (s=0x0, format=0x8054def "\n--",
ap=0xbfffe968)
    at vfprintf.c:271
#1  0x40079ed7 in fprintf (stream=0x0, format=0x8054def "\n--") at
fprintf.c:32
#2  0x804b468 in strcpy () at ../sysdeps/generic/strcpy.c:31
#3  0x804a0ff in strcpy () at ../sysdeps/generic/strcpy.c:31
#4  0x4003b345 in __libc_start_main (main=0x804a010 <strcpy+1264>, argc=1, 
    ubp_av=0xbffffa84, init=0x8049460, fini=0x80543fc <strcpy+43228>, 
    rtld_fini=0x4000de14 <_dl_fini>, stack_end=0xbffffa7c)
    at ../sysdeps/generic/libc-start.c:111
(gdb)
Comment 1 Jeremy Katz 2000-08-06 00:14:33 EDT
*** Bug 15212 has been marked as a duplicate of this bug. ***
Comment 2 Brock Organ 2000-08-06 12:49:39 EDT
verified in test lab ... thanks for your report!
Comment 3 Nalin Dahyabhai 2000-08-07 17:43:11 EDT
Fixed in 1.1.21-12.
Comment 4 Jeff Johnson 2000-10-25 12:22:21 EDT
*** Bug 19752 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.