Bug 19752 - warning printed when running new ping
warning printed when running new ping
Status: CLOSED DUPLICATE of bug 19952
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2000-10-25 09:54 EDT by Nadav Har'El
Modified: 2015-03-04 20:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-07 14:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nadav Har'El 2000-10-25 09:54:40 EDT
After upgrading to iputils-20001010-1.i386.rpm (from the updates
distribution), every time
I run ping, to any host, I get the following warning printed:
           Warning: no SO_TIMESTAMP support, falling back to SIOCGSTAMP

I don't know exactly what this means, but I guess that it's not very
important (does any Linux
kernel support this SO_TIMESTAMP option?), and it probably should not be
printed all the

If I remember correctly, this warning wasn't printed when I used Redhat 7's
original ping
(before the update came out).
Comment 1 Jeff Johnson 2000-10-25 12:22:03 EDT
This is the fix to bugzilla #15523.
Comment 2 Jeff Johnson 2000-10-25 12:22:24 EDT

*** This bug has been marked as a duplicate of 15523 ***
Comment 3 Nadav Har'El 2000-10-25 12:32:51 EDT
I hope I'm not making an ass out of myself, but I reported a ping bug in your
newest ping update,
and you marked it as a duplicate of some old mgetty bug in an old beta
version... As hard as I
tried to look, I can't find a connection... Am I missing something, or is this
simply a wrong resolution?
Comment 4 Jeff Johnson 2000-10-25 12:38:34 EDT
You are looking at the message that results from a fix to negative time stamps
in $15573.
It turns out that there are 2 ways of acquiring time stamps, and, if time goes
then the 2nd method is used (with notification to user as reported by you).
Comment 5 Nadav Har'El 2000-10-25 12:44:07 EDT
I see, 15573, not 15523 as you wrote... Anyway, somehow I don't have permissions
to see bug
#15573 (!). Anyway, I still don't understand why the user should care about
these details seeing
this message everytime they use ping.
But I guess this is not a very important problem, so I guess you can reclose
this bug if you want.
Comment 6 Raul Acevedo 2001-01-23 03:09:18 EST
So, what is the resolution to this bug?

It's annoying... is something actually wrong with the system?  Is this related
to some other bug?
Comment 7 Phil Knirsch 2001-06-16 10:49:28 EDT
I have closed this bug as a duplicate of the other 'bugs' concerning this
explicit WARNING message.

As explaing in the bug threads in the other related bugreports this is merely a
problem with the 2.2 kernel which doesn't have SO_TIMESTAMP support.

As of 7.1 we ship the 2.4 kernel with the distribution, so you won't get the
warning anymore. And if you use ping on RH 7.1 with an old 2.2 kernel it should
still report that this kernel doesn't support this specific feature.
All in all you could either consider this bug to be closed as CURRENT RELEASE or
NOTABUG as well (it's not a bug, it's a warning ;).

Read ya, Phil

PS: If it REALLY bothers a lot more people i can easily remove this warning, but
i'd rather leave it in (people might then complain that they weren't warned! :)

*** This bug has been marked as a duplicate of 19952 ***

Note You need to log in before you can comment on or make changes to this bug.