Bug 1553395 - OSP-12 undercloud installation fails in os-refresh-config - configure phase (configure-oci-register-machine)
Summary: OSP-12 undercloud installation fails in os-refresh-config - configure phase (...
Keywords:
Status: CLOSED DUPLICATE of bug 1553291
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-08 19:17 UTC by Ronelle Landy
Modified: 2018-03-08 19:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-08 19:20:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ronelle Landy 2018-03-08 19:17:26 UTC
Description of problem:

osp-12 gates are failing to install the undercloud since March 7th. The error shows in https://thirdparty.logs.rdoproject.org/jenkins-tqe-gate-rhos-12-ci-rhos-ovb-minimal-pacemaker-public-bond-737/undercloud/home/stack/undercloud_install.log.txt.gz#_2018-03-08_11_15_52

...

2018-03-08 10:59:22 | 2018-03-08 10:59:22,295 INFO: [1;31mError: /Stage[main]/Tripleo::Profile::Base::Docker/File_line[configure-oci-register-machine]: Could not evaluate: No such file or directory - /etc/oci-register-machine.conf[0m

...

ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2018-03-08 11:15:52 | 2018-03-08 11:15:52,838 INFO: 
2018-03-08 11:15:52 | 2018-03-08 11:15:52,838 INFO: [2018-03-08 11:15:52,838] (os-refresh-config) [ERROR] Aborting...
2018-03-08 11:15:52 | 2018-03-08 11:15:52,845 DEBUG: An exception occurred
2018-03-08 11:15:52 | Traceback (most recent call last):
2018-03-08 11:15:52 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1869, in install
2018-03-08 11:15:52 |     _run_orc(instack_env)
2018-03-08 11:15:52 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1383, in _run_orc
2018-03-08 11:15:52 |     _run_live_command(args, instack_env, 'os-refresh-config')
2018-03-08 11:15:52 |   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 620, in _run_live_command
2018-03-08 11:15:52 |     raise RuntimeError('%s failed. See log for details.' % name)
2018-03-08 11:15:52 | RuntimeError: os-refresh-config failed. See log for details.

Version-Release number of selected component (if applicable):
OSP-12 (http://<download>/rcm-guest/puddles/OpenStack/rhos-release/rhos-release-latest.noarch.rpm
## ::


How reproducible:

The test jobs have been failing consistently all of today (March 8th)

Steps to Reproduce:
1. Install OSP-12 from latest (see tripleo-environments.git/tree/config/release/rhos-12.yml)
2. Run the undercloud install step
3. See errors

Actual results:

The undercloud installation fails to complete

Expected results:

The undercloud install passes.

Additional info:

Comment 1 Ronelle Landy 2018-03-08 19:20:52 UTC

*** This bug has been marked as a duplicate of bug 1553291 ***


Note You need to log in before you can comment on or make changes to this bug.