Bug 1554248 - Import error in validation "Compare switch port VLANs to VLANs in nic config"
Summary: Import error in validation "Compare switch port VLANs to VLANs in nic config"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Florian Fuchs
QA Contact: Udi
URL:
Whiteboard:
: 1561408 (view as bug list)
Depends On:
Blocks: 1471531
TreeView+ depends on / blocked
 
Reported: 2018-03-12 08:57 UTC by Udi
Modified: 2020-05-27 09:24 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-validations-8.4.1-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:35:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1761717 None None None 2018-04-06 10:14:52 UTC
OpenStack gerrit 563969 None MERGED Fix Switch VLANs validation 2020-05-27 09:16:41 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:57 UTC

Description Udi 2018-03-12 08:57:16 UTC
Description of problem:
The validation fails with a Python import error:

Task 'Check that switch vlans are present if used in nic-config files' failed:
Host: localhost
Message: MODULE FAILURE

stderr:
    Traceback (most recent call last):
      File "/tmp/ansible_ee3Uft/ansible_module_switch_vlans.py", line 23, in <module>
        import validations.library.network_environment as net_utils
    ImportError: No module named validations.library.network_environment

Failure! The validation failed for all hosts:
* localhost


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-8.3.1-0.20180304031640.d5546cd.el7.centos.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install Queens with quickstart
2. Log in to TripleoUI
3. Start a deployment of 1 controller and 1 compute
4. Wait for the pre-deployment validations to complete


Actual results:
The validator "Compare switch port VLANs to VLANs in nic config" fails with an import error.

Comment 6 Udi 2018-05-16 12:44:07 UTC
Verified in: openstack-tripleo-validations-8.4.1-5.el7ost.noarch

The validator now generates multiple warnings. A new bug was opened: https://bugzilla.redhat.com/show_bug.cgi?id=1578828

Comment 8 errata-xmlrpc 2018-06-27 13:35:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086

Comment 9 Jan Buchta 2020-05-27 09:24:40 UTC
*** Bug 1561408 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.