Bug 1554336 - Bump pyOpenSSL to >= 17.1.0
Summary: Bump pyOpenSSL to >= 17.1.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: pyOpenSSL
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jon Schlueter
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On: 1554409
Blocks: 1553520
TreeView+ depends on / blocked
 
Reported: 2018-03-12 13:35 UTC by Carlos Goncalves
Modified: 2018-06-27 13:35 UTC (History)
5 users (show)

Fixed In Version: pyOpenSSL-17.3.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1554409 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:35:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:57 UTC

Description Carlos Goncalves 2018-03-12 13:35:27 UTC
Description of problem:

Octavia (Queens release) requires pyOpenSSL >= 17.1.0, even though octavia/requirements.txt suggests pyOpenSSL>=16.2.0 [1]. It should have been proposed to requirements project to bump minimum pyOpenSSL in global-requirements.txt but that slipped. See bz#1553520 for Octavia bug report.


Version-Release number of selected component (if applicable):

At the moment pyOpenSSL version being distributed is python-pyOpenSSL-16.2.0-3.el7ost.noarch

How reproducible: 100%


[1] https://github.com/openstack/octavia/blob/stable/queens/requirements.txt#L35

Comment 4 errata-xmlrpc 2018-06-27 13:35:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.