Bug 1554409 - Bump pyOpenSSL to >= 17.1.0
Summary: Bump pyOpenSSL to >= 17.1.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: distribution
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: trunk
Assignee: Lars Kellogg-Stedman
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On: 1553517
Blocks: 1553520 1554336
TreeView+ depends on / blocked
 
Reported: 2018-03-12 15:55 UTC by Carlos Goncalves
Modified: 2018-03-30 20:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1554336
Environment:
Last Closed: 2018-03-30 20:55:24 UTC


Attachments (Terms of Use)

Description Carlos Goncalves 2018-03-12 15:55:21 UTC
+++ This bug was initially created as a clone of Bug #1554336 +++

Description of problem:

Octavia (Queens release) requires pyOpenSSL >= 17.1.0, even though octavia/requirements.txt suggests pyOpenSSL>=16.2.0 [1]. It should have been proposed to requirements project to bump minimum pyOpenSSL in global-requirements.txt but that slipped. See bz#1553520 for Octavia bug report.


Version-Release number of selected component (if applicable):

At the moment pyOpenSSL version being distributed is python-pyOpenSSL-16.2.0-3.el7ost.noarch

How reproducible: 100%


[1] https://github.com/openstack/octavia/blob/stable/queens/requirements.txt#L35

Comment 1 Alfredo Moralejo 2018-03-15 15:04:05 UTC
New pyOpenSSL requires updated python-cryptography so this update is blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1553517


Note You need to log in before you can comment on or make changes to this bug.