Bug 155465 - Note needed about upgrading of mod_perl
Note needed about upgrading of mod_perl
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Wade
Tammy Fox
http://fedoraproject.org/wiki/FedoraD...
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2005-04-20 12:26 EDT by Jose Pedro Oliveira
Modified: 2007-04-18 13:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 07:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2005-04-20 12:26:57 EDT
Description of problem, and enhancement request:

This week mod_perl was updated to the latest version (2.0.0 RC5).
The main problem is that this version is incompatible with
all previous versions: several perl modules were renamed
from Apache:: to Apache2::.  This will break every application
that depends on mod_perl.

A warning about this problem should be added to the FC4 release notes.


Version of release notes this bug refers to:
FC4test3 with mod_perl-2.0.0rc5

URL of bug/enhancement (change if different):
More information on the problem:
http://search.cpan.org/~geoff/mod_perl-2.0.0-RC5/Changes
Comment 1 Joe Orton 2005-04-26 08:17:48 EDT
Suggested text to add to the "Web server" section:

mod_perl

The "RC5" release of mod_perl 2.0 is now included; the API provided by this
release is incompatible with previous 1.99_xx releases.  Please see the
following document for discussion of how to adapt code to use the new API:
 
   http://perl.apache.org/docs/2.0/rename.html   
Comment 2 Karsten Wade 2005-05-04 07:57:53 EDT
Included in relnotes for FC3test3.

Note You need to log in before you can comment on or make changes to this bug.