Bug 1555304 - Check 'Single PCI' according to chosen operating system after VM creation
Summary: Check 'Single PCI' according to chosen operating system after VM creation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.4.0
: ---
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-14 12:51 UTC by Radek Duda
Modified: 2020-06-26 16:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-19 13:05:54 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4?
rbarry: ovirt-4.5?


Attachments (Terms of Use)

Description Radek Duda 2018-03-14 12:51:57 UTC
Description of problem:

When user creates some VM in RHV webadmin portal, 'Single PCI' checkbox is checked or disabled (unchecked) according to chosen operating system. For example if RHEL 6.x is chosen, check-box is checked - if Windows OS is chosen, check-box is disabled.

Lets say we have VM of some operating system by choice of which the check-box is disabled (e.g. Windows OS VM).
If 'Operating system' is edited after VM creation to e.g. RHEL 6.x, Single PCI checkbox is not automatically checked as is before VM creation.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.2.2-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.2.2.2-0.1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1.create new VM of some operating system when 'Single PCI' checkbox is set to disabled state (e.g. Windows*, Other OS..) in rhv admin portal
 1a. notice 'Single PCI' checkbox is automatically checked if some RHEL6/7 OS is chosen
2. Edit this VM and set operating system to type when 'Single PCI' checkbox should be checked (e.g. RHEL6/7)

Actual results:
'Single PCI' checkbox is not checked

Expected results:
'Single PCI' checkbox should be checked like during VM creation step.

Additional info:

Comment 1 Ryan Barry 2019-01-03 12:49:34 UTC
This will not be addressed in a reasonable timeframe. Please re-open if it's still important.

Comment 2 Radek Duda 2019-01-03 17:04:33 UTC
I reproduced this again in latest rhv4.2.
The thing here is that multiple PCI is not supported for Linux guests - that means (from my experience) they usually become unstable.
See https://bugzilla.redhat.com/show_bug.cgi?id=1428340#c17
https://bugzilla.redhat.com/show_bug.cgi?id=1428340#c18
https://bugzilla.redhat.com/show_bug.cgi?id=1428340#c19
and Doc text of the same bug. Therefor I think it is not good to unnecessarily increase probabilty for user to have linux VM with multiple PCI devices.

I do not why single PCI checkbox exists at all after such discussion .. maybe it is time to get rid of it.

Either way, if you want to get rid of checkbox or not, IMHO to correct checkbox behaviour according to drop down list is pretty low hanging fruit.

Comment 3 Michal Skrivanek 2019-01-04 11:15:55 UTC
Tou reproduced the crash with RHEL 7.6?

Comment 4 Radek Duda 2019-01-04 13:06:39 UTC
(In reply to Michal Skrivanek from comment #3)
> Tou reproduced the crash with RHEL 7.6?

You probably mean crash from https://bugzilla.redhat.com/show_bug.cgi?id=1428340 ? No I cannot reproduce this. But multiple monitors (Monitors>1) does not work with rhel7.6 guest when I set multiple PCI devices ('Singe PCI' is not set). Only one display is available.

Comment 5 Michal Skrivanek 2020-03-18 15:45:44 UTC
This bug didn't get any attention for a while, we didn't have the capacity to make any progress. If you deeply care about it or want to work on it please assign/target accordingly

Comment 6 Michal Skrivanek 2020-03-18 15:50:39 UTC
This bug didn't get any attention for a while, we didn't have the capacity to make any progress. If you deeply care about it or want to work on it please assign/target accordingly

Comment 7 Radek Duda 2020-03-19 13:05:54 UTC
'Single PCI' checkbox is not present in rhv-4.4.0-0.25.master.el8ev. So closing this.


Note You need to log in before you can comment on or make changes to this bug.