Bug 1556797 - [kernel] swiotlb buffer is full
Summary: [kernel] swiotlb buffer is full
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1571454 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-15 09:34 UTC by Joachim Frieben
Modified: 2018-05-29 11:09 UTC (History)
38 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-21 14:03:47 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 104082 None None None 2018-03-15 09:36 UTC

Description Joachim Frieben 2018-03-15 09:34:42 UTC
Description of problem:
Output of command 'dmesg' exhibits error multiple blocks reading:

[..] radeon 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[..] radeon 0000:01:00.0: swiotlb: coherent allocation failed, size=2097152
[..] CPU: 0 PID: 4111 Comm: gnome-shell Tainted: G        W        4.16.0-0.rc5.git0.1.fc28.x86_64 #1
[..] Hardware name: LENOVO 2768W9J/2768W9J, BIOS 7UET94WW (3.24 ) 10/17/2012
[..] Call Trace:
[..]  dump_stack+0x5c/0x85
[..]  swiotlb_alloc_coherent+0x1c3/0x1e0
[..]  ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
[..]  ttm_dma_populate+0xdd/0x390 [ttm]
[..]  ttm_tt_bind+0x2e/0x60 [ttm]
[..]  ttm_bo_handle_move_mem+0x4cf/0x550 [ttm]
[..]  ttm_bo_validate+0x119/0x130 [ttm]
[..]  ? drm_add_edid_modes+0x46/0x1840 [drm]
[..]  ttm_bo_init_reserved+0x334/0x380 [ttm]
[..]  ? ttm_bo_init+0x62/0xd0 [ttm]
[..]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[..]  ? radeon_bo_create+0x184/0x220 [radeon]
[..]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[..]  ? radeon_gem_object_create+0xa7/0x1c0 [radeon]
[..]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[..]  ? radeon_gem_create_ioctl+0x66/0x100 [radeon]
[..]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[..]  ? drm_ioctl_kernel+0x5b/0xb0 [drm]
[..]  ? drm_ioctl+0x1c4/0x380 [drm]
[..]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[..]  ? __slab_free+0x141/0x2e0
[..]  ? update_load_avg+0x75/0x520
[..]  ? radeon_drm_ioctl+0x49/0x80 [radeon]
[..]  ? do_vfs_ioctl+0xa4/0x610
[..]  ? SyS_ioctl+0x74/0x80
[..]  ? do_syscall_64+0x74/0x180
[..]  ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2

Version-Release number of selected component (if applicable):
kernel-4.16.0-0.rc5.git0.1.fc28

How reproducible:
Frequently

Steps to Reproduce:
1. Boot current Fedora 28 on system with AMD Radeon RV620 video device.
2. Run GNOME session.

Actual results:
Swiotlb buffer is reported to be full all the time.

Expected results:
Swiotlb buffer is not running out of memory.

Additional info:
None

Comment 1 Joachim Frieben 2018-03-15 09:36:26 UTC
Issue has been resolved for Fedora 27, see bug 1546449.

Comment 2 John Reiser 2018-03-18 17:52:32 UTC
nouveau has the same problem.

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 710] [10de:128b] (rev a1)

kernel: nouveau 0000:01:00.0: NVIDIA GK208B (b060b0b1)
kernel: nouveau 0000:01:00.0: bios: version 80.28.a6.00.01
kernel: nouveau 0000:01:00.0: fb: 1024 MiB DDR3
kernel: nouveau 0000:01:00.0: DRM: VRAM: 1024 MiB
kernel: nouveau 0000:01:00.0: DRM: GART: 1048576 MiB
kernel: nouveau 0000:01:00.0: DRM: TMDS table version 2.0
kernel: nouveau 0000:01:00.0: DRM: DCB version 4.0
kernel: nouveau 0000:01:00.0: DRM: DCB outp 00: 01000f02 00020030
kernel: nouveau 0000:01:00.0: DRM: DCB outp 01: 02011f62 00020010
kernel: nouveau 0000:01:00.0: DRM: DCB outp 02: 02022f10 00000000
kernel: nouveau 0000:01:00.0: DRM: DCB conn 00: 00001031
kernel: nouveau 0000:01:00.0: DRM: DCB conn 01: 00002161
kernel: nouveau 0000:01:00.0: DRM: DCB conn 02: 00000200
kernel: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
kernel: [drm] Driver supports precise vblank timestamp query.
kernel: nouveau 0000:01:00.0: DRM: MM: using COPY for buffer copies
kernel: nouveau 0000:01:00.0: DRM: allocated 1920x1080 fb: 0x60000, bo 000000006fa64a86
kernel: fbcon: nouveaufb (fb0) is primary device


I saw 1070 repetitions of these messages when a GNOME Terminal was scrolling hundreds of thousands of long lines of text:

nouveau 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
nouveau 0000:01:00.0: swiotlb: coherent allocation failed, size=2097152
CPU: 2 PID: 1776 Comm: gnome-shell Not tainted 4.16.0-0.rc5.git0.2.fc28.x86_64 #1
Hardware name: Hewlett-Packard HP Compaq 8200 Elite SFF PC/1495, BIOS J01 v02.15 11/10/2011
Call Trace:
 dump_stack+0x5c/0x85
 swiotlb_alloc_coherent+0x1c3/0x1e0
 ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
 ttm_dma_populate+0xdd/0x390 [ttm]
 ttm_tt_bind+0x2e/0x60 [ttm]
 ttm_bo_handle_move_mem+0x4cf/0x550 [ttm]
 ttm_bo_validate+0x119/0x130 [ttm]
 ? drm_rect_clip_scaled+0x126/0x160 [drm]
 ttm_bo_init_reserved+0x334/0x380 [ttm]
 ? ttm_bo_init+0x62/0xd0 [ttm]
 ? nouveau_bo_invalidate_caches+0x10/0x10 [nouveau]
 ? nouveau_bo_new+0x401/0x580 [nouveau]
 ? nouveau_bo_invalidate_caches+0x10/0x10 [nouveau]
 ? nouveau_gem_new+0x120/0x120 [nouveau]
 ? nouveau_gem_new+0x5d/0x120 [nouveau]
 ? nouveau_gem_ioctl_new+0x53/0xe0 [nouveau]
 ? drm_ioctl_kernel+0x5b/0xb0 [drm]
 ? drm_ioctl+0x1c4/0x380 [drm]
 ? nouveau_gem_new+0x120/0x120 [nouveau]
 ? eventfd_write+0x94/0x2a0
 ? nouveau_drm_ioctl+0x65/0xc0 [nouveau]
 ? do_vfs_ioctl+0xa4/0x610
 ? SyS_ioctl+0x74/0x80
 ? do_syscall_64+0x74/0x180
 ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2

Comment 3 John Reiser 2018-03-18 18:00:06 UTC
xorg-x11-drv-nouveau-1.0.15-4.fc28.x86_64

Comment 5 Joachim Frieben 2018-05-07 01:24:45 UTC
*** Bug 1571454 has been marked as a duplicate of this bug. ***

Comment 6 Nicola 2018-05-09 02:08:50 UTC
Alas, still no luck on F27 x64 with latest kernel
4.16.6-202.fc27.x86_64.
xorg-x11-drv-amdgpu-18.0.1-1.fc27.x86_64

Again, have not seen it in kernel  4.16.3-200 and previous ones.

[82582.873612] amdgpu 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[82582.873613] amdgpu 0000:01:00.0: swiotlb: coherent allocation failed, size=2097152
[82582.873615] CPU: 6 PID: 1979 Comm: Xorg Not tainted 4.16.6-202.fc27.x86_64 #1
[82582.873616] Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./990FX Extreme4, BIOS P2.70 06/05/2014
[82582.873617] Call Trace:
[82582.873621]  dump_stack+0x5c/0x85
[82582.873624]  swiotlb_alloc_coherent+0x1be/0x1d0
[82582.873631]  ttm_dma_pool_get_pages+0x235/0x620 [ttm]
[82582.873635]  ttm_dma_populate+0x25e/0x350 [ttm]
[82582.873639]  ttm_tt_bind+0x2c/0x60 [ttm]
[82582.873642]  ttm_bo_handle_move_mem+0x577/0x5b0 [ttm]
[82582.873646]  ttm_bo_validate+0x120/0x130 [ttm]
[82582.873664]  ? do_detailed_mode+0x34e/0x5a0 [drm]
[82582.873667]  ttm_bo_init_reserved+0x378/0x420 [ttm]
[82582.873721]  amdgpu_bo_do_create+0x22e/0x4b0 [amdgpu]
[82582.873750]  ? amdgpu_fill_buffer+0x300/0x300 [amdgpu]
[82582.873778]  amdgpu_bo_create+0x4f/0x2c0 [amdgpu]
[82582.873780]  ? __wake_up_common_lock+0x89/0xc0
[82582.873809]  amdgpu_gem_object_create+0x7f/0x110 [amdgpu]
[82582.873839]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[82582.873867]  amdgpu_gem_create_ioctl+0x1d4/0x260 [amdgpu]
[82582.873896]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[82582.873905]  drm_ioctl_kernel+0x5b/0xb0 [drm]
[82582.873913]  drm_ioctl+0x2d5/0x370 [drm]
[82582.873942]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[82582.873944]  ? vfs_writev+0xb9/0x110
[82582.873972]  amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
[82582.873974]  do_vfs_ioctl+0xa4/0x620
[82582.873975]  SyS_ioctl+0x74/0x80
[82582.873978]  do_syscall_64+0x74/0x180
[82582.873980]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[82582.873982] RIP: 0033:0x7f62d8cec0f7
[82582.873983] RSP: 002b:00007ffcbebe04c8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[82582.873984] RAX: ffffffffffffffda RBX: 00000000047fbe90 RCX: 00007f62d8cec0f7
[82582.873984] RDX: 00007ffcbebe0510 RSI: 00000000c0206440 RDI: 000000000000000d
[82582.873985] RBP: 00007ffcbebe0510 R08: 00000000047fbe90 R09: 0000000000000004
[82582.873986] R10: 0000000002371010 R11: 0000000000000246 R12: 00000000c0206440
[82582.873986] R13: 000000000000000d R14: 00007ffcbebe0598 R15: 00000000049b2070

Comment 7 John Levon 2018-05-09 09:36:11 UTC
I have never seen this up to and including:

4.15.17-300.fc27.x86_64

On the recent update to:

kernel-4.16.6-202.fc27.x86_64

I see this very soon after booting while using the desktop. Example:

May  9 10:19:47 pent kernel: RIP: 0033:0x7fa09f56b0f7
May  9 10:19:47 pent kernel: RSP: 002b:00007ffd24d05478 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
May  9 10:19:47 pent kernel: RAX: ffffffffffffffda RBX: 0000000000000002 RCX: 00007fa09f56b0f7
May  9 10:19:47 pent kernel: RDX: 00007ffd24d054f0 RSI: 00000000c020645d RDI: 000000000000000b
May  9 10:19:47 pent kernel: RBP: 00007ffd24d054f0 R08: 0000000000000002 R09: 0000000000000000
May  9 10:19:47 pent kernel: R10: 00007ffd24d054c0 R11: 0000000000000246 R12: 00000000c020645d
May  9 10:19:47 pent kernel: R13: 000000000000000b R14: 000000000258e530 R15: 000000000258e530
May  9 10:19:47 pent kernel: radeon 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
May  9 10:19:47 pent kernel: radeon 0000:01:00.0: swiotlb: coherent allocation failed, size=2097152
May  9 10:19:47 pent kernel: CPU: 3 PID: 1699 Comm: Xwayland Not tainted 4.16.6-202.fc27.x86_64 #1
May  9 10:19:47 pent kernel: Hardware name: Dell Inc. Precision T1500/0P67HD, BIOS 2.4.0 01/13/2011
May  9 10:19:47 pent kernel: Call Trace:
May  9 10:19:47 pent kernel: dump_stack+0x5c/0x85
May  9 10:19:47 pent kernel: swiotlb_alloc_coherent+0x1be/0x1d0
May  9 10:19:47 pent kernel: ttm_dma_pool_get_pages+0x235/0x620 [ttm]
May  9 10:19:47 pent kernel: ttm_dma_populate+0x25e/0x350 [ttm]
May  9 10:19:48 pent kernel: ttm_tt_bind+0x2c/0x60 [ttm]
May  9 10:19:48 pent kernel: ttm_bo_handle_move_mem+0x577/0x5b0 [ttm]
May  9 10:19:48 pent kernel: ttm_bo_validate+0x120/0x130 [ttm]
May  9 10:19:48 pent kernel: ? drm_pcie_get_speed_cap_mask+0x8e/0xe0 [drm]
May  9 10:19:48 pent kernel: ttm_bo_init_reserved+0x378/0x420 [ttm]
May  9 10:19:48 pent kernel: ttm_bo_init+0x62/0xd0 [ttm]
May  9 10:19:48 pent kernel: ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
May  9 10:19:48 pent kernel: radeon_bo_create+0x180/0x230 [radeon]
May  9 10:19:48 pent kernel: ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
May  9 10:19:48 pent kernel: radeon_gem_object_create+0xa7/0x1d0 [radeon]
May  9 10:19:48 pent kernel: ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May  9 10:19:48 pent kernel: radeon_gem_create_ioctl+0x66/0x100 [radeon]
May  9 10:19:48 pent kernel: ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May  9 10:19:48 pent kernel: drm_ioctl_kernel+0x5b/0xb0 [drm]
May  9 10:19:48 pent kernel: drm_ioctl+0x2d5/0x370 [drm]
May  9 10:19:48 pent kernel: ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May  9 10:19:48 pent kernel: ? __do_fault+0x1f/0x130
May  9 10:19:48 pent kernel: ? __handle_mm_fault+0xd2b/0x12f0
May  9 10:19:48 pent kernel: radeon_drm_ioctl+0x49/0x80 [radeon]
May  9 10:19:48 pent kernel: do_vfs_ioctl+0xa4/0x620
May  9 10:19:48 pent kernel: ? __audit_syscall_entry+0xbc/0x110
May  9 10:19:48 pent kernel: ? syscall_trace_enter+0x1df/0x2e0
May  9 10:19:48 pent kernel: SyS_ioctl+0x74/0x80
May  9 10:19:48 pent kernel: do_syscall_64+0x74/0x180
May  9 10:19:48 pent kernel: entry_SYSCALL_64_after_hwframe+0x3d/0xa2

Comment 8 Anton Lapikhin 2018-05-14 10:05:44 UTC
The same problem:


[ 4189.033174] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 4189.033180] radeon 0000:01:05.0: swiotlb: coherent allocation failed, size=2097152
[ 4189.033183] CPU: 1 PID: 7764 Comm: chrome Tainted: G      D          4.16.7-300.fc28.x86_64 #1
[ 4189.033185] Hardware name: System manufacturer System Product Name/M4A78LT-M, BIOS 0802    08/24/2010
[ 4189.033186] Call Trace:
[ 4189.033195]  dump_stack+0x5c/0x85
[ 4189.033198]  swiotlb_alloc_coherent+0x1c3/0x1e0
[ 4189.033207]  ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
[ 4189.033213]  ttm_dma_populate+0xdd/0x390 [ttm]
[ 4189.033217]  ttm_tt_bind+0x2e/0x60 [ttm]
[ 4189.033222]  ttm_bo_handle_move_mem+0x4cd/0x530 [ttm]
[ 4189.033226]  ttm_bo_validate+0x119/0x130 [ttm]
[ 4189.033251]  ? drm_pci_alloc+0x6/0x1b0 [drm]
[ 4189.033255]  ttm_bo_init_reserved+0x334/0x380 [ttm]
[ 4189.033259]  ? ttm_bo_init+0x62/0xd0 [ttm]
[ 4189.033303]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.033318]  ? radeon_bo_create+0x184/0x220 [radeon]
[ 4189.033333]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.033349]  ? radeon_gem_object_create+0xa7/0x1c0 [radeon]
[ 4189.033365]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.033380]  ? radeon_gem_create_ioctl+0x66/0x100 [radeon]
[ 4189.033396]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.033405]  ? drm_ioctl_kernel+0x5b/0xb0 [drm]
[ 4189.033414]  ? drm_ioctl+0x1c0/0x380 [drm]
[ 4189.033430]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.033444]  ? radeon_drm_ioctl+0x49/0x80 [radeon]
[ 4189.033447]  ? do_vfs_ioctl+0xa4/0x610
[ 4189.033449]  ? SyS_ioctl+0x74/0x80
[ 4189.033451]  ? do_syscall_64+0x74/0x180
[ 4189.033454]  ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[ 4189.094280] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 4189.094285] radeon 0000:01:05.0: swiotlb: coherent allocation failed, size=2097152
[ 4189.094289] CPU: 1 PID: 7764 Comm: chrome Tainted: G      D          4.16.7-300.fc28.x86_64 #1
[ 4189.094291] Hardware name: System manufacturer System Product Name/M4A78LT-M, BIOS 0802    08/24/2010
[ 4189.094292] Call Trace:
[ 4189.094301]  dump_stack+0x5c/0x85
[ 4189.094304]  swiotlb_alloc_coherent+0x1c3/0x1e0
[ 4189.094313]  ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
[ 4189.094318]  ttm_dma_populate+0xdd/0x390 [ttm]
[ 4189.094323]  ttm_tt_bind+0x2e/0x60 [ttm]
[ 4189.094327]  ttm_bo_handle_move_mem+0x4cd/0x530 [ttm]
[ 4189.094332]  ttm_bo_validate+0x119/0x130 [ttm]
[ 4189.094353]  ? drm_pci_alloc+0x6/0x1b0 [drm]
[ 4189.094357]  ttm_bo_init_reserved+0x334/0x380 [ttm]
[ 4189.094361]  ? ttm_bo_init+0x62/0xd0 [ttm]
[ 4189.094391]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.094406]  ? radeon_bo_create+0x184/0x220 [radeon]
[ 4189.094421]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.094437]  ? radeon_gem_object_create+0xa7/0x1c0 [radeon]
[ 4189.094453]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.094468]  ? radeon_gem_create_ioctl+0x66/0x100 [radeon]
[ 4189.094484]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.094493]  ? drm_ioctl_kernel+0x5b/0xb0 [drm]
[ 4189.094502]  ? drm_ioctl+0x1c0/0x380 [drm]
[ 4189.094518]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.094522]  ? __handle_mm_fault+0xdb3/0x12f0
[ 4189.094536]  ? radeon_drm_ioctl+0x49/0x80 [radeon]
[ 4189.094538]  ? do_vfs_ioctl+0xa4/0x610
[ 4189.094540]  ? handle_mm_fault+0xda/0x200
[ 4189.094542]  ? __do_page_fault+0x263/0x4e0
[ 4189.094543]  ? SyS_ioctl+0x74/0x80
[ 4189.094546]  ? do_syscall_64+0x74/0x180
[ 4189.094548]  ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[ 4189.152566] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 4189.152572] radeon 0000:01:05.0: swiotlb: coherent allocation failed, size=2097152
[ 4189.152575] CPU: 2 PID: 7764 Comm: chrome Tainted: G      D          4.16.7-300.fc28.x86_64 #1
[ 4189.152577] Hardware name: System manufacturer System Product Name/M4A78LT-M, BIOS 0802    08/24/2010
[ 4189.152578] Call Trace:
[ 4189.152586]  dump_stack+0x5c/0x85
[ 4189.152590]  swiotlb_alloc_coherent+0x1c3/0x1e0
[ 4189.152600]  ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
[ 4189.152606]  ttm_dma_populate+0xdd/0x390 [ttm]
[ 4189.152610]  ttm_tt_bind+0x2e/0x60 [ttm]
[ 4189.152615]  ttm_bo_handle_move_mem+0x4cd/0x530 [ttm]
[ 4189.152620]  ttm_bo_validate+0x119/0x130 [ttm]
[ 4189.152624]  ttm_bo_init_reserved+0x334/0x380 [ttm]
[ 4189.152629]  ? ttm_bo_init+0x62/0xd0 [ttm]
[ 4189.152665]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.152681]  ? radeon_bo_create+0x184/0x220 [radeon]
[ 4189.152696]  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
[ 4189.152712]  ? radeon_gem_object_create+0xa7/0x1c0 [radeon]
[ 4189.152727]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.152743]  ? radeon_gem_create_ioctl+0x66/0x100 [radeon]
[ 4189.152759]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.152786]  ? drm_ioctl_kernel+0x5b/0xb0 [drm]
[ 4189.152795]  ? drm_ioctl+0x1c0/0x380 [drm]
[ 4189.152811]  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
[ 4189.152815]  ? __handle_mm_fault+0xb88/0x12f0
[ 4189.152817]  ? __switch_to_asm+0x34/0x70
[ 4189.152831]  ? radeon_drm_ioctl+0x49/0x80 [radeon]
[ 4189.152834]  ? do_vfs_ioctl+0xa4/0x610
[ 4189.152836]  ? handle_mm_fault+0xda/0x200
[ 4189.152838]  ? __do_page_fault+0x263/0x4e0
[ 4189.152840]  ? SyS_ioctl+0x74/0x80
[ 4189.152843]  ? do_syscall_64+0x74/0x180
[ 4189.152844]  ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2




Version-Release number:

1. fedora 28 workstation KDE spin x86_64

2. Linux 4.16.7-300.fc28.x86_64 #1 SMP Wed May 2 20:09:13 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

3. xorg-x11-drv-ati.x86_64   18.0.1-1.fc28

4. libdrm.x86_64   2.4.91-1.fc28


Additional info:

Motherboard: M4A78LT-M

CPU: AMD Athlon(tm) II X3 455 Processor

Videocard: AMD RS780 (DRM 2.50.0 / 4.16.7-300.fc28.x86_64, LLVM 6.0.0) (0x9616)

Comment 9 Anton Lapikhin 2018-05-15 07:45:34 UTC
with latest fedora 28 kernel:

Linux 4.16.8-300.fc28.x86_64 #1 SMP Wed May 9 20:23:40 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

in dmesg:

[ 3872.299737] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3872.380151] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3872.516737] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3872.706098] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3872.875228] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3873.023425] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3873.174151] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 3873.286484] radeon 0000:01:05.0: swiotlb buffer is full (sz: 2097152 bytes)

Comment 10 Scott Dowdle 2018-05-15 19:31:00 UTC
I'm having this issue too... on a Dell Optiplex 9010 with a Radeon HD 7570.  I've also been having occasional wild swings in RAM and swap usage.  Stuff will just start swapping to disk when there is plenty of free RAM available usually after starting a KVM VM that gobbles up a bunch of RAM quickly (but still, plenty of free RAM is available).  Doing a "swapoff -a" for a little while will make the system usable again.

Anyway, here's my kernel log related to the bug report:

May 15 13:06:03 hostname-redacted kernel: swiotlb_tbl_map_single: 28 callbacks suppressed
May 15 13:06:03 hostname-redacted kernel: radeon 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
May 15 13:06:03 hostname-redacted kernel: radeon 0000:01:00.0: swiotlb: coherent allocation failed, size=2097152
May 15 13:06:03 hostname-redacted kernel: CPU: 1 PID: 1097 Comm: Xorg Not tainted 4.16.7-300.fc28.x86_64 #1
May 15 13:06:03 hostname-redacted kernel: Hardware name: Dell Inc. OptiPlex 9010/0M9KCM, BIOS A27 12/28/2017
May 15 13:06:03 hostname-redacted kernel: Call Trace:
May 15 13:06:03 hostname-redacted kernel:  dump_stack+0x5c/0x85
May 15 13:06:03 hostname-redacted kernel:  swiotlb_alloc_coherent+0x1c3/0x1e0
May 15 13:06:03 hostname-redacted kernel:  ttm_dma_pool_get_pages+0x21a/0x620 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ttm_dma_populate+0xdd/0x390 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ttm_tt_bind+0x2e/0x60 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ttm_bo_handle_move_mem+0x4cd/0x530 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ttm_bo_validate+0x119/0x130 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ? drm_mode_set_crtcinfo.part.2+0x66/0x1d0 [drm]
May 15 13:06:03 hostname-redacted kernel:  ttm_bo_init_reserved+0x334/0x380 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ? ttm_bo_init+0x62/0xd0 [ttm]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_bo_create+0x184/0x220 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_update_memory_usage.isra.3+0x50/0x50 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_gem_object_create+0xa7/0x1c0 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_gem_create_ioctl+0x66/0x100 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? drm_ioctl_kernel+0x5b/0xb0 [drm]
May 15 13:06:03 hostname-redacted kernel:  ? drm_ioctl+0x1c0/0x380 [drm]
May 15 13:06:03 hostname-redacted kernel:  ? radeon_gem_pwrite_ioctl+0x30/0x30 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? ep_scan_ready_list.constprop.19+0x20c/0x230
May 15 13:06:03 hostname-redacted kernel:  ? radeon_drm_ioctl+0x49/0x80 [radeon]
May 15 13:06:03 hostname-redacted kernel:  ? do_vfs_ioctl+0xa4/0x610
May 15 13:06:03 hostname-redacted kernel:  ? SyS_ioctl+0x74/0x80
May 15 13:06:03 hostname-redacted kernel:  ? do_syscall_64+0x74/0x180
May 15 13:06:03 hostname-redacted kernel:  ? entry_SYSCALL_64_after_hwframe+0x3d/0xa2

Comment 11 Fedora Update System 2018-05-17 12:56:03 UTC
kernel-4.16.9-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-155b62b226

Comment 12 Fedora Update System 2018-05-17 12:56:31 UTC
kernel-4.16.9-200.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0a96d42a8

Comment 13 Fedora Update System 2018-05-17 12:56:45 UTC
kernel-4.16.9-300.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-538a7a0e36

Comment 14 Fedora Update System 2018-05-19 01:47:42 UTC
kernel-4.16.9-200.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a0a96d42a8

Comment 15 Fedora Update System 2018-05-19 02:31:44 UTC
kernel-4.16.9-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-155b62b226

Comment 16 Fedora Update System 2018-05-19 04:19:59 UTC
kernel-4.16.9-300.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-538a7a0e36

Comment 17 Fedora Update System 2018-05-21 14:03:47 UTC
kernel-4.16.9-300.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-05-22 16:35:40 UTC
kernel-4.16.9-200.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-05-23 00:39:05 UTC
kernel-4.16.11-100.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6367a17aa3

Comment 20 Fedora Update System 2018-05-23 16:56:50 UTC
kernel-4.16.11-100.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6367a17aa3

Comment 21 Fedora Update System 2018-05-29 11:09:38 UTC
kernel-4.16.11-100.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.