Bug 15608 - sound starts even with "enable sound server startup" unchecked
sound starts even with "enable sound server startup" unchecked
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Elliot Lee
Winston gold
:
: 15801 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 03:29 EDT by Jeremy Katz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-23 20:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2000-08-07 03:29:13 EDT
(note: component here is a little nebulous -- could just as easily be a
gnome-libs or gnomecc bug)

On a fresh install of pinstripe with sound configured, logging into GNOME
has the GNOME sounds actually working although gnomecc has the button for
"enable sound server startup" unchecked.  The button for "sounds for
events" is checked though.  Checking the sound server startup allows me to
turn off sounds for events and then I can turn the sound server back off
leaving me with a quiet gnome again, but there should be consistency in the
options enabled and the options shown as being enabled :)
Comment 1 Jeremy Katz 2000-08-07 03:54:25 EDT
actually, that's a lie... just the sounds in gnomecc stopped.  I went to remove
a couple of the default panel apps and it started making sounds at me again. 
:(  

So, it seems that just disabling sounds for events and disabling the sound
server startup aren't enough to get rid of sounds :(
Comment 2 Glen Foster 2000-08-07 13:48:39 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 3 Elliot Lee 2000-08-21 14:24:07 EDT
*** Bug 15801 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2000-08-22 18:57:07 EDT
Steps I've taken to reproduce flawlessly --

- log in as root, create new account testXXX.  set password for account.  make
sure sound is configured 
- log out and log back in as the test account on ttyX
- startx
- sounds playing, click on gnomecc launcher in panel
- click on sound.  note that "Enable sound server startup" is unchecked
- check the enable button, uncheck sounds for events, and uncheck the enable
sound server startup
-  click on OK
- remove gnomecc launcher from panel.  sound still plays
Comment 5 Elliot Lee 2000-08-23 20:35:20 EDT
Fixed in gnome-libs-1.2.4-11
Comment 6 Jeremy Katz 2000-08-23 23:49:48 EDT
Fix works for me

Note You need to log in before you can comment on or make changes to this bug.