Bug 15801 - sound-slot-0 is not aliased when there is no sound card
sound-slot-0 is not aliased when there is no sound card
Status: CLOSED DUPLICATE of bug 15608
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 08:57 EDT by Arenas Belon, Carlo Marcelo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-14 11:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2000-08-09 08:57:07 EDT
when a system with no sound card is installed alias sound-slot-0 off should
be added to /etc/modules.conf for getting gnome of complaining every other
minute
Comment 1 Michael Fulbright 2000-08-09 10:49:19 EDT
The installer cannot tell if a sound card is installed or not.

Perhaps this is something kudzu could do.
Comment 2 Bill Nottingham 2000-08-09 12:33:46 EDT
kudzu can't detect the *lack* of a sound card, only the
presence of pci/isapnp ones.
Comment 3 Bill Nottingham 2000-08-11 12:23:00 EDT
In this case the best thing to do is probably not start
the sound server if it can't detect an alias for
sound-slot-0 or 'sound', and sound isn't listed
in /proc/devices...
Comment 4 Preston Brown 2000-08-14 11:04:07 EDT
esd should only be started if sound support is present.  We will fix this for
7.1 most likely.
Comment 5 Elliot Lee 2000-08-21 14:24:11 EDT
I'm going to merge this in with jrb's bug on esound, since it sounds that aside
from the unsolvable problem with detecting the absence of a sound card, the main
problem could be esound using the sound device when GNOME sounds are turned
off...?

*** This bug has been marked as a duplicate of 15608 ***

Note You need to log in before you can comment on or make changes to this bug.