Bug 1561996 - [trello XzkI9of3] Deploy Image page cannot pull and deploy private image successfully after creating pull secret
Summary: [trello XzkI9of3] Deploy Image page cannot pull and deploy private image succ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1578088
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-29 10:22 UTC by Xingxing Xia
Modified: 2018-07-23 13:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:14:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xingxing Xia 2018-03-29 10:22:45 UTC
Description of problem:
Deploy Image page cannot pull and deploy private image successfully after creating pull secret

Version-Release number of selected component (if applicable):
v3.10.0-0.15.0

How reproducible:
Always

Steps to Reproduce:
1. First prepare a private registry image, e.g. docker.io/starxia/myprivate:hello-openshift
2. On OCP web console, click 'Deploy Image'.
3. Under 'Image Name', input above private image, click the search icon, it will show 'Could not load image metadata'.
4. Then click 'create an image pull secret', input right user, password etc, click 'Link secret to a service account', select 'default'.
5. Repeat step 3, now private image can be searched. Click 'Deploy'.
Then check app pod status

Actual results:
4. Check the web-created secret, its format is still old .dockercfg.
5. App pod cannot be running, its status is ErrImagePull and ImagePullBackOff.

Expected results:
4. Web-created secret format should be consistent with command which uses .dockerconfigjson:
$ oc create secret docker-registry mydocker --docker-server=docker.io --docker-username=starxia --docker-password=$MYPASSWORD --docker-email=$MYEMAIL
5. App pod should be running.

Additional info:
There is https://github.com/openshift/origin-web-console/pull/2464 for the format issue, but not merged.

Comment 1 Jakub Hadvig 2018-04-05 14:05:25 UTC
PR https://github.com/openshift/origin-web-console/pull/2464 was merged. Please try to reproduce the issue now.

Comment 2 Xingxing Xia 2018-04-08 06:41:02 UTC
Checked in env:
OpenShift Master: v3.10.0-0.16.0
Kubernetes Master: v1.9.1+a0ce1bc657
OpenShift Web Console: v3.10.0-0.16.0
Now web-created pull secret has same '.dockerconfigjson' format with `oc create secret docker-registry ...`. But still it cannot pull private image and pod is ErrImagePull/ImagePullBackOff status due to bug 1561989. Waiting for that bug addressed ...

Comment 4 Xingxing Xia 2018-05-16 08:26:12 UTC
Still depending on bug 1561989

Comment 5 Xingxing Xia 2018-05-29 02:28:47 UTC
Per https://bugzilla.redhat.com/show_bug.cgi?id=1561989#c55, tested this bug on web. Issue fixed and pod with private docker.io image can be running. Moving to VERIFIED


Note You need to log in before you can comment on or make changes to this bug.