Bug 1578088 - [3.9] Secret created by `oc create secret docker-registry` cannot pull image from external private registry
Summary: [3.9] Secret created by `oc create secret docker-registry` cannot pull image ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.9.z
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On: 1561989 1600539
Blocks: 1561996
TreeView+ depends on / blocked
 
Reported: 2018-05-14 19:04 UTC by Seth Jennings
Modified: 2018-07-12 13:01 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue pulling images from a private docker hub registry
Clone Of: 1561989
Environment:
Last Closed: 2018-06-06 15:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1796 None None None 2018-06-06 15:46:42 UTC

Comment 3 weiwei jiang 2018-05-30 06:26:47 UTC
Checked with 
# oc version 
oc v3.9.30
kubernetes v1.9.1+a0ce1bc657
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-3-197.ec2.internal:8443
openshift v3.9.30
kubernetes v1.9.1+a0ce1bc657

And the issue can not be reproduced.

Comment 5 errata-xmlrpc 2018-06-06 15:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1796


Note You need to log in before you can comment on or make changes to this bug.