Bug 156208 - djvulibre - FC4 rebuild failed
Summary: djvulibre - FC4 rebuild failed
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: djvulibre
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 164382 (view as bug list)
Depends On:
Blocks: FE4Target
TreeView+ depends on / blocked
 
Reported: 2005-04-28 13:04 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 18:19:00 UTC


Attachments (Terms of Use)
spec patch (1.05 KB, patch)
2005-07-28 22:52 UTC, Michael Schwendt
no flags Details | Diff
patch0 required by spec patch (377 bytes, patch)
2005-07-28 22:53 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2005-04-28 13:04:16 UTC
This package failed to rebuild for FC4 Development around 2005-04-11 after an
automated release bump.

Architectures: i386 ppc

Build failure logs at: http://fedoraproject.org/extras/development/build-logs/

Comment 1 Michael Schwendt 2005-05-09 01:11:47 UTC
Build fails due to SMP make flags. Lazy fix suggestion:

--- djvulibre.spec.~1.8.~       2005-04-07 00:11:36.000000000 +0200
+++ djvulibre.spec      2005-05-09 00:28:21.000000000 +0200
@@ -36,7 +36,7 @@
 
 %build
 %configure
-%{__make} %{?_smp_mflags}
+%{__make} %{?_smp_mflags} || %{__make}
 
 
 %install


Comment 2 Michael Schwendt 2005-05-09 01:14:38 UTC
Or better, just drop smp_mflags as to avoid any other race condition...

Comment 3 Matthias Saou 2005-05-09 08:55:38 UTC
From the digging I've done, this is definitely not the (only) issue. Some stuff,
namely the .desktop file, is only installed with older Qt/kdelibs it seems, so
some further spec file changes are required.
I'm already working on it, but feel free to provide a patch to the spec file if
you really want to.

Comment 4 Michael Schwendt 2005-07-27 20:30:35 UTC
*** Bug 164382 has been marked as a duplicate of this bug. ***

Comment 5 Michael Schwendt 2005-07-28 22:52:10 UTC
Created attachment 117250 [details]
spec patch

With these changes, it built for FC4.

Comment 6 Michael Schwendt 2005-07-28 22:53:07 UTC
Created attachment 117251 [details]
patch0 required by spec patch

Comment 7 Matthias Saou 2005-08-04 18:19:00 UTC
Sorry Michael, I hadn't seen those two attachements until now, and worked on
getting djvulibre to build independently. Using 3.5.15 (released not long ago,
and not yet linked on the main web page) fixed the gcc4 issue, and as I wrote,
some further changes were required to get everything straight, since the
configure script does some checking for files and directories to know what
mime/desktop/etc. files should be installed.

New packages of 3.5.15 should be available real soon.


Note You need to log in before you can comment on or make changes to this bug.