Bug 1562098 - openshift-ansible fails on docker version even though it is set correctly
Summary: openshift-ansible fails on docker version even though it is set correctly
Keywords:
Status: CLOSED DUPLICATE of bug 1551862
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.7.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-29 14:04 UTC by August Simonelli
Modified: 2018-04-10 15:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description August Simonelli 2018-03-29 14:04:50 UTC
Description of problem:

Docs say to install docker with a specific version. I did so:

subscription-manager repos \
    --enable="rhel-7-server-rpms" \
    --enable="rhel-7-server-extras-rpms" \
    --enable="rhel-7-server-ose-3.7-rpms" \
    --enable="rhel-7-fast-datapath-rpms"


yum install docker-1.12.6 -y

And to confirm:

[root@master-0 ~]# rpm -qa | grep docker
docker-1.12.6-71.git3e8e77d.el7.x86_64
docker-client-1.12.6-71.git3e8e77d.el7.x86_64
python-docker-pycreds-1.10.6-3.el7.noarch
docker-rhel-push-plugin-1.12.6-71.git3e8e77d.el7.x86_64
docker-common-1.12.6-71.git3e8e77d.el7.x86_64
python-docker-2.4.2-1.3.el7.noarch

but be aware:

[root@master-0 ~]# yum list available | grep docker
atomic-openshift-docker-excluder.noarch
atomic-openshift-dockerregistry.x86_64
cockpit-docker.x86_64           160-1.el7             rhel-7-server-extras-rpms
docker.x86_64                   2:1.13.1-53.git774336d.el7
docker-client.x86_64            2:1.13.1-53.git774336d.el7
docker-client-latest.x86_64     1.13.1-53.git774336d.el7
docker-common.x86_64            2:1.13.1-53.git774336d.el7
docker-distribution.x86_64      2.6.2-1.git48294d9.el7
docker-forward-journald.x86_64  1.10.3-44.el7         rhel-7-server-extras-rpms
docker-latest.x86_64            1.13.1-53.git774336d.el7
docker-latest-logrotate.x86_64  1.13.1-53.git774336d.el7
docker-latest-v1.10-migrator.x86_64
docker-logrotate.x86_64         2:1.13.1-53.git774336d.el7
docker-lvm-plugin.x86_64        2:1.13.1-53.git774336d.el7
docker-novolume-plugin.x86_64   2:1.13.1-53.git774336d.el7
docker-python.x86_64            1.4.0-115.el7         rhel-7-server-extras-rpms
docker-registry.noarch          0.6.8-8.el7           rhel-7-server-extras-rpms
docker-registry.x86_64          0.9.1-7.el7           rhel-7-server-extras-rpms
docker-rhel-push-plugin.x86_64  2:1.13.1-53.git774336d.el7
docker-selinux.x86_64           1.10.3-57.el7         rhel-7-server-extras-rpms
docker-unit-test.x86_64         2:1.12.6-32.git88a4867.el7
docker-v1.10-migrator.x86_64    2:1.13.1-53.git774336d.el7
jenkins-plugin-docker-commons.x86_64
jenkins-plugin-docker-workflow.x86_64
openvswitch-ovn-docker.x86_64   2.7.2-1.git20170719.el7fdp
python-docker-py.noarch         1.10.6-3.el7          rhel-7-server-extras-rpms
rubygem-docker-api.noarch       1.22.4-2.el7          rhel-7-server-ose-3.7-rpms
rubygem-docker-api-doc.noarch   1.22.4-2.el7          rhel-7-server-ose-3.7-rpms
rubygem-fluent-plugin-docker_metadata_filter.noarch
rubygem-fluent-plugin-docker_metadata_filter-doc.noarch

When i went to install I got this error:

  1. Hosts:    master-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-1.internal.ocp3.demorack.lab.eng.rdu.redhat.com
     Play:     OpenShift Health Checks
     Task:     Run health checks (install) - EL
     Message:  One or more checks failed
     Details:  check "package_version":
               Some required package(s) are available at a version
               that is higher than requested
                 docker-1.13.1
               This will prevent installing the version you requested.
               Please check your enabled repositories or adjust openshift_release.

So i tried:

yum install yum-plugin-versionlock
yum versionlock docker

which failed the same way. 

Then added 

openshift_disable_check=package_version

to my inventory file.

This allowed me get past the error.

Version-Release number of the following components:

[root@master-0 ~]# rpm -q openshift-ansible
openshift-ansible-3.7.23-1.git.0.bc406aa.el7.noarch
[root@master-0 ~]# rpm -q ansible
ansible-2.4.2.0-2.el7.noarch
[root@master-0 ~]# ansible --version
ansible 2.4.2.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

How reproducible:

Follow steps in description.

Steps to Reproduce:
see above.

Actual results:
  1. Hosts:    master-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-1.internal.ocp3.demorack.lab.eng.rdu.redhat.com
     Play:     OpenShift Health Checks
     Task:     Run health checks (install) - EL
     Message:  One or more checks failed
     Details:  check "package_version":
               Some required package(s) are available at a version
               that is higher than requested
                 docker-1.13.1
               This will prevent installing the version you requested.
               Please check your enabled repositories or adjust openshift_release.
Expected results:

Using the correct version will allow me to install. Installer should know this.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag
will try to get.

Comment 1 August Simonelli 2018-03-29 14:06:24 UTC
docs bug raised just in case:

https://bugzilla.redhat.com/show_bug.cgi?id=1562099

disabling the check worked so we could mention that until it gets resolved.

Comment 2 Scott Dodson 2018-04-10 15:17:19 UTC
This was fixed in https://github.com/openshift/openshift-ansible/pull/7347 which is included in openshift-ansible-3.7.42-1.git.2.9ee4e71.el7

Comment 3 Scott Dodson 2018-04-10 15:17:41 UTC
(which shipped last week)

Comment 4 Scott Dodson 2018-04-10 15:19:31 UTC

*** This bug has been marked as a duplicate of bug 1551862 ***


Note You need to log in before you can comment on or make changes to this bug.