Bug 1562099 - advanced install fails on docker version even if correct version installed.
Summary: advanced install fails on docker version even if correct version installed.
Keywords:
Status: CLOSED DUPLICATE of bug 1551862
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-29 14:05 UTC by August Simonelli
Modified: 2018-04-10 15:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:20:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description August Simonelli 2018-03-29 14:05:32 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/openshift_container_platform/3.7/html-single/installation_and_configuration/#installing-docker

Section Number and Name: 

2.3.4. Installing Docker

Describe the issue: 

Docs say to install docker with a specific version. I did so:

yum install docker-1.12.6 -y

And to confirm:

[root@master-0 ~]# rpm -qa | grep docker
docker-1.12.6-71.git3e8e77d.el7.x86_64
docker-client-1.12.6-71.git3e8e77d.el7.x86_64
python-docker-pycreds-1.10.6-3.el7.noarch
docker-rhel-push-plugin-1.12.6-71.git3e8e77d.el7.x86_64
docker-common-1.12.6-71.git3e8e77d.el7.x86_64
python-docker-2.4.2-1.3.el7.noarch

but be aware:

[root@master-0 ~]# yum list available | grep docker
atomic-openshift-docker-excluder.noarch
atomic-openshift-dockerregistry.x86_64
cockpit-docker.x86_64           160-1.el7             rhel-7-server-extras-rpms
docker.x86_64                   2:1.13.1-53.git774336d.el7
docker-client.x86_64            2:1.13.1-53.git774336d.el7
docker-client-latest.x86_64     1.13.1-53.git774336d.el7
docker-common.x86_64            2:1.13.1-53.git774336d.el7
docker-distribution.x86_64      2.6.2-1.git48294d9.el7
docker-forward-journald.x86_64  1.10.3-44.el7         rhel-7-server-extras-rpms
docker-latest.x86_64            1.13.1-53.git774336d.el7
docker-latest-logrotate.x86_64  1.13.1-53.git774336d.el7
docker-latest-v1.10-migrator.x86_64
docker-logrotate.x86_64         2:1.13.1-53.git774336d.el7
docker-lvm-plugin.x86_64        2:1.13.1-53.git774336d.el7
docker-novolume-plugin.x86_64   2:1.13.1-53.git774336d.el7
docker-python.x86_64            1.4.0-115.el7         rhel-7-server-extras-rpms
docker-registry.noarch          0.6.8-8.el7           rhel-7-server-extras-rpms
docker-registry.x86_64          0.9.1-7.el7           rhel-7-server-extras-rpms
docker-rhel-push-plugin.x86_64  2:1.13.1-53.git774336d.el7
docker-selinux.x86_64           1.10.3-57.el7         rhel-7-server-extras-rpms
docker-unit-test.x86_64         2:1.12.6-32.git88a4867.el7
docker-v1.10-migrator.x86_64    2:1.13.1-53.git774336d.el7
jenkins-plugin-docker-commons.x86_64
jenkins-plugin-docker-workflow.x86_64
openvswitch-ovn-docker.x86_64   2.7.2-1.git20170719.el7fdp
python-docker-py.noarch         1.10.6-3.el7          rhel-7-server-extras-rpms
rubygem-docker-api.noarch       1.22.4-2.el7          rhel-7-server-ose-3.7-rpms
rubygem-docker-api-doc.noarch   1.22.4-2.el7          rhel-7-server-ose-3.7-rpms
rubygem-fluent-plugin-docker_metadata_filter.noarch
rubygem-fluent-plugin-docker_metadata_filter-doc.noarch

When i went to install I got this error:

  1. Hosts:    master-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-0.internal.ocp3.demorack.lab.eng.rdu.redhat.com, node-1.internal.ocp3.demorack.lab.eng.rdu.redhat.com
     Play:     OpenShift Health Checks
     Task:     Run health checks (install) - EL
     Message:  One or more checks failed
     Details:  check "package_version":
               Some required package(s) are available at a version
               that is higher than requested
                 docker-1.13.1
               This will prevent installing the version you requested.
               Please check your enabled repositories or adjust openshift_release.

So i tried:

yum install yum-plugin-versionlock
yum versionlock docker

which failed the same way. 

Then added 

openshift_disable_check=package_version

to my inventory file.

This allowed me get past the error.

Suggestions for improvement: 

Probably the installer needs fixing. I raised this:

https://bugzilla.redhat.com/show_bug.cgi?id=1562098

But at a minimum docs will need to reflect issue as it stops the install.

Additional information:

Comment 1 Scott Dodson 2018-04-10 15:20:06 UTC
This issue has already been fixed in the latest installer.

*** This bug has been marked as a duplicate of bug 1551862 ***


Note You need to log in before you can comment on or make changes to this bug.