Bug 1563125 - rubygem-rkerberos-0.1.3-5.el7.x86_64 fails to install on RHEL7.5
Summary: rubygem-rkerberos-0.1.3-5.el7.x86_64 fails to install on RHEL7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-rkerberos
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Cleal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1568470 1568829 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-03 08:07 UTC by Lukas Pramuk
Modified: 2018-05-03 15:03 UTC (History)
6 users (show)

Fixed In Version: rubygem-rkerberos-0.1.3-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 15:03:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Pramuk 2018-04-03 08:07:06 UTC
Description of problem:
rubygem-rkerberos fails to install on RHEL7.5 since libkadm5 changed its provides
 
rubygem-rkerberos-0.1.3-5.el7.x86_64 (epel)
     Requires: libkadm5clnt_mit.so.8()(64bit)

In RHEL7.5 libkadm5 package switched to provide libkadm5clnt_mit.so.11()(64bit)
(soname version bump so.8 > so.11)

See https://bugzilla.redhat.com/show_bug.cgi?id=1462982#c6
So please rebuild rubygem-rkerberos against new libkadm5 library

Version-Release number of selected component (if applicable):
rubygem-rkerberos-0.1.3-5.el7.x86_64


How reproducible:
deterministic

Steps to Reproduce:
1. Have a RHEL7.5
2. Enable EPEL7
3. # yum install rubygem-rkerberos
...
Error: Package: rubygem-rkerberos-0.1.3-5.el7.x86_64 (epel)
           Requires: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.11.3-49.el7.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.12.2-14.el7.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.12.2-15.el7_1.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.13.2-10.el7.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: krb5-libs-1.13.2-12.el7_2.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: libkadm5-1.14.1-26.el7.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: libkadm5-1.14.1-27.el7_3.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Available: libkadm5-1.15.1-8.el7.x86_64 (rhel-7-server-rpms)
               libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)
           Installed: krb5-libs-1.15.1-18.el7.x86_64 (@rhel75_repo)
               Not found
           Installed: libkadm5-1.15.1-18.el7.x86_64 (@rhel75_repo)
              ~libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)

Actual results:
failed dependencies

Expected results:
new rebuilt package has no failed deps

Comment 1 Vít Ondruch 2018-04-03 08:21:38 UTC
This will be problem as soon as RHEL 7.5 is released. There is just beta so far. In EPEL7, there is just krb5-devel-1.15.1-8.el7.x86_64 ATM so there is no problem yet. Please update the ticket as soon as RHEL 7.5 is released.

Comment 2 Bishop Clark 2018-04-14 16:02:14 UTC
Will this ticket be moot with bug 1563780 ?

Comment 3 Fedora Update System 2018-04-16 13:18:26 UTC
rubygem-rkerberos-0.1.3-6.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-90207015c0

Comment 4 Fedora Update System 2018-04-18 02:12:01 UTC
rubygem-rkerberos-0.1.3-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-90207015c0

Comment 5 Evgeni Golov 2018-04-18 09:57:56 UTC
*** Bug 1568829 has been marked as a duplicate of this bug. ***

Comment 6 Evgeni Golov 2018-04-18 09:58:48 UTC
*** Bug 1568470 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2018-05-03 15:03:24 UTC
rubygem-rkerberos-0.1.3-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.