Bug 1568829 - please rebuild rubygem-rkerberos to update dependency on libkadm5clnt_mit.so from EL7.5
Summary: please rebuild rubygem-rkerberos to update dependency on libkadm5clnt_mit.so ...
Keywords:
Status: CLOSED DUPLICATE of bug 1563125
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-rkerberos
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Cleal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 09:56 UTC by Evgeni Golov
Modified: 2018-04-18 09:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 09:57:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Evgeni Golov 2018-04-18 09:56:36 UTC
Description of problem:
(moslty copied from https://bugzilla.redhat.com/show_bug.cgi?id=1330431)

The current version of rubygem-rkerberos requires libkadm5clnt_mit.so.8. This is quite unfortunate as functions provided by this lib are not considered stable by upstream [1] and it may change with krb5 rebase. If it changes (what happened with RHEL-7.2 and with RHEL-7.3), krb5 has no other option than pretending that it is still providing the old version [2]. This is a very bad practice, IMHO.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1166012#c5
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1292153#c24

In EL7.5, krb5 switched to provide libkadm5clnt_mit.so.11 and that makes rubygem-rkerberos uninstallable.

While the proper solution would be not depending on the kadm libs, a rebuild (as soon as EL7.5 buildroots are available for EPEL) would fix the issue for the users.

Version-Release number of selected component (if applicable):
rubygem-rkerberos-0.1.3-5.el7

How reproducible:
always

Steps to Reproduce:
% rpm -q --requires -p rubygem-rkerberos-0.1.3-5.el7.x86_64.rpm |grep kadm
libkadm5clnt_mit.so.8()(64bit)
libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit)

Expected result:
% rpm -q --requires -p rubygem-rkerberos-0.1.3-5.el7.x86_64.rpm |grep kadm
libkadm5clnt_mit.so.11()(64bit)
libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)

Comment 1 Evgeni Golov 2018-04-18 09:57:56 UTC

*** This bug has been marked as a duplicate of bug 1563125 ***


Note You need to log in before you can comment on or make changes to this bug.