Bug 1563600 - [Regression] Unexpected error while opening GCE details page
Summary: [Regression] Unexpected error while opening GCE details page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Zita Nemeckova
QA Contact: Ganesh Hubale
URL:
Whiteboard:
: 1568851 1573067 (view as bug list)
Depends On:
Blocks: 1571303
TreeView+ depends on / blocked
 
Reported: 2018-04-04 09:23 UTC by thiebaut fischer
Modified: 2019-02-11 14:06 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1571303 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:06:01 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
unexpected error page (40.86 KB, image/png)
2018-04-04 09:23 UTC, thiebaut fischer
no flags Details
unexpected error cloud Intel (59.20 KB, image/png)
2018-04-09 07:37 UTC, thiebaut fischer
no flags Details

Description thiebaut fischer 2018-04-04 09:23:16 UTC
Created attachment 1417155 [details]
unexpected error page

Description of problem:

Unexpected error page while opening GCE.
worked in previous versions

Version-Release number of selected component (if applicable):
 Version 5.9.2.0.20180320210136_355c506 

How reproducible:
Always

Steps to Reproduce:
1.create a gce provider,
2.go to its details

Actual results:
error page

Expected results:
See its details

Additional info:
works on other providers.
See screenshot

Comment 3 Zita Nemeckova 2018-04-05 14:37:22 UTC
https://github.com/ManageIQ/manageiq-schema/pull/184

Comment 4 thiebaut fischer 2018-04-09 07:37:29 UTC
Created attachment 1419133 [details]
unexpected error cloud Intel

Comment 5 CFME Bot 2018-04-10 15:42:59 UTC
New commit detected on ManageIQ/manageiq-schema/master:

https://github.com/ManageIQ/manageiq-schema/commit/ad28f50af007c46504fc3f5aa7a1865cb8ece907
commit ad28f50af007c46504fc3f5aa7a1865cb8ece907
Author:     Zita Nemeckova <znemecko@redhat.com>
AuthorDate: Thu Apr  5 10:23:26 2018 -0400
Commit:     Zita Nemeckova <znemecko@redhat.com>
CommitDate: Thu Apr  5 10:23:26 2018 -0400

    Update provider_region to nil for ManageIQ::Providers::Google::CloudManager

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1563600

 db/migrate/20180405145642_remove_provider_region_for_google_provider.rb | 11 +
 spec/migrations/20180405145642_remove_provider_region_for_google_provider_spec.rb | 20 +
 2 files changed, 31 insertions(+)

Comment 6 Zita Nemeckova 2018-04-18 14:26:34 UTC
*** Bug 1568851 has been marked as a duplicate of this bug. ***

Comment 7 thiebaut fischer 2018-04-23 07:47:46 UTC
I checked on  5.9.2.3.20180419182310_cab2891  and it is not fixed.

Comment 8 Zita Nemeckova 2018-04-23 07:55:17 UTC
My mistake. 5.9 have another fix.

https://github.com/ManageIQ/manageiq-ui-classic/pull/3735

Comment 10 Tomas Coufal 2018-05-10 14:15:25 UTC
*** Bug 1573067 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.