Bug 1563644 - fix restoreconfig failure
Summary: fix restoreconfig failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rtslib
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 1554642 1566105
TreeView+ depends on / blocked
 
Reported: 2018-04-04 11:43 UTC by Prasanna Kumar Kalever
Modified: 2018-10-30 07:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1566105 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:44:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3019 0 None None None 2018-10-30 07:45:34 UTC

Description Prasanna Kumar Kalever 2018-04-04 11:43:47 UTC
Description of problem:
fix restoreconfig failure

Problem:
-------
$ cat myconfig.json
{
  "storage_objects": [
    {
      "alua_tpgs": [
        {
          "alua_access_type": 0,
          "name": "glfs_tg_pt_gp",
          "tg_pt_gp_id": 1
        }
      ],
      "config": "glfs/test@192.168.124.227/block-store/2e189467-00ae-4388-bbd2-a8b4df154671",
      "name": "blockX",
      "plugin": "user",
      "size": 1073741824
    }
  ],
  "targets": []
}

$ targetcli restoreconfig myconfig.json
All configuration cleared
'alua_access_state'

And attributes won't be effected as per myconfig.json:
$ targetcli/backstores/user:glfs/blockX/alua/glfs_tg_pt_gp get alua alua_access_type
alua_access_type=3

Comment 2 Prasanna Kumar Kalever 2018-04-04 11:44:35 UTC
Proposed fix: https://github.com/open-iscsi/rtslib-fb/pull/127

Comment 3 Prasanna Kumar Kalever 2018-04-05 05:46:14 UTC
(In reply to Prasanna Kumar Kalever from comment #2)
> Proposed fix: https://github.com/open-iscsi/rtslib-fb/pull/127

Merged upstream now.

Comment 5 Maurizio Lombardi 2018-04-11 14:34:17 UTC
Fixed in python-rtslib-2.1.fb63-8.el7: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=15766137

Comment 7 Martin Hoyer 2018-07-10 10:26:50 UTC
Tested with: 
 - kernel-3.10.0-915.el7
 - targetcli-2.1.fb46-6.el7
 - python-configshell-1.1.fb23-4.el7
 - python-rtslib-2.1.fb63-12.el7
The issue is no longer reproducible; No regression found.

Comment 9 errata-xmlrpc 2018-10-30 07:44:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3019


Note You need to log in before you can comment on or make changes to this bug.