Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566105 - fix restoreconfig failure [rhel-7.5.z]
Summary: fix restoreconfig failure [rhel-7.5.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rtslib
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
Marek Suchánek
URL:
Whiteboard:
Depends On: 1563644
Blocks: 1555191
TreeView+ depends on / blocked
 
Reported: 2018-04-11 14:17 UTC by Oneata Mircea Teodor
Modified: 2018-05-14 16:12 UTC (History)
9 users (show)

Fixed In Version: python-rtslib-2.1.fb63-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1563644
Environment:
Last Closed: 2018-05-14 16:12:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1402 0 None None None 2018-05-14 16:12:42 UTC

Description Oneata Mircea Teodor 2018-04-11 14:17:22 UTC
This bug has been copied from bug #1563644 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 4 Sweta Anandpara 2018-05-04 11:50:32 UTC
Validated on a RHGS cluster having the build python-rtslib-2.1.fb63-11.el7.noarch.

Created 2 blocks, saved the configuration, moved the file to a local location (say, /home), cleared the targetcli configuration, and restored it from the saved file. Verified that the blocks initially created were correctly shown in targetcli ls output. Again saved the configuration of targetcli and executed a diff of '/etc/target/saveconfig.json' with the originally saved file in /home. They were the same. 

I do see the below errors while restoring the config, and Prasanna (developer) says they are to be noted and not to be worried for, at the moment. 
[root@dhcp47-65 ~]# targetcli restoreconfig /home/saveconfig.json 
Configuration restored, 4 recoverable errors:
Storage Object user/ob2: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob2: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped
Storage Object user/ob1: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob1: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped

This is good for the validation of the patch that has gone in in this bug. Please feel free to move this bug to verified after a round of regressions. Thanks!

Logs are pasted below:

[root@dhcp47-65 ~]# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................. [Storage Objects: 0]
  | o- fileio ................................................................................................. [Storage Objects: 0]
  | o- pscsi .................................................................................................. [Storage Objects: 0]
  | o- ramdisk ................................................................................................ [Storage Objects: 0]
  | o- user:glfs .............................................................................................. [Storage Objects: 2]
  |   o- ob1 .............................. [ozone@10.70.47.65/block-store/717aaa86-7efa-4dd7-94e0-19156ff23893 (10.0MiB) activated]
  |   | o- alua ................................................................................................... [ALUA Groups: 1]
  |   |   o- default_tg_pt_gp ....................................................................... [ALUA state: Active/optimized]
  |   o- ob2 .............................. [ozone@10.70.47.65/block-store/4f125360-8917-497b-b67d-b7ddd766ae2e (10.0MiB) activated]
  |     o- alua ................................................................................................... [ALUA Groups: 1]
  |       o- default_tg_pt_gp ....................................................................... [ALUA state: Active/optimized]
  o- iscsi ............................................................................................................ [Targets: 2]
  | o- iqn.2016-12.org.gluster-block:4f125360-8917-497b-b67d-b7ddd766ae2e ................................................ [TPGs: 1]
  | | o- tpg1 .................................................................................................. [gen-acls, no-auth]
  | |   o- acls .......................................................................................................... [ACLs: 0]
  | |   o- luns .......................................................................................................... [LUNs: 1]
  | |   | o- lun0 .................................................................................... [user/ob2 (default_tg_pt_gp)]
  | |   o- portals .................................................................................................... [Portals: 1]
  | |     o- 10.70.47.65:3260 ................................................................................................. [OK]
  | o- iqn.2016-12.org.gluster-block:717aaa86-7efa-4dd7-94e0-19156ff23893 ................................................ [TPGs: 1]
  |   o- tpg1 .................................................................................................. [gen-acls, no-auth]
  |     o- acls .......................................................................................................... [ACLs: 0]
  |     o- luns .......................................................................................................... [LUNs: 1]
  |     | o- lun0 .................................................................................... [user/ob1 (default_tg_pt_gp)]
  |     o- portals .................................................................................................... [Portals: 1]
  |       o- 10.70.47.65:3260 ................................................................................................. [OK]
  o- loopback ......................................................................................................... [Targets: 0]
[root@dhcp47-65 ~]# ls /home/
ldb_tools  rhel75-rc  saveconfig-20180504-04:54:22.json  saveconfig.json
[root@dhcp47-65 ~]# targetcli clearconfig confirm=True
All configuration cleared
[root@dhcp47-65 ~]# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................. [Storage Objects: 0]
  | o- fileio ................................................................................................. [Storage Objects: 0]
  | o- pscsi .................................................................................................. [Storage Objects: 0]
  | o- ramdisk ................................................................................................ [Storage Objects: 0]
  | o- user:glfs .............................................................................................. [Storage Objects: 0]
  o- iscsi ............................................................................................................ [Targets: 0]
  o- loopback ......................................................................................................... [Targets: 0]
[root@dhcp47-65 ~]# targetcli restoreconfig /home/saveconfig.json 
Configuration restored, 4 recoverable errors:
Storage Object user/ob2: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob2: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped
Storage Object user/ob1: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob1: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# targetcli / saveconfig
Configuration saved to /etc/target/saveconfig.json
[root@dhcp47-65 ~]# targetcli ls
o- / ......................................................................................................................... [...]
  o- backstores .............................................................................................................. [...]
  | o- block .................................................................................................. [Storage Objects: 0]
  | o- fileio ................................................................................................. [Storage Objects: 0]
  | o- pscsi .................................................................................................. [Storage Objects: 0]
  | o- ramdisk ................................................................................................ [Storage Objects: 0]
  | o- user:glfs .............................................................................................. [Storage Objects: 2]
  |   o- ob1 .............................. [ozone@10.70.47.65/block-store/717aaa86-7efa-4dd7-94e0-19156ff23893 (10.0MiB) activated]
  |   | o- alua ................................................................................................... [ALUA Groups: 1]
  |   |   o- default_tg_pt_gp ....................................................................... [ALUA state: Active/optimized]
  |   o- ob2 .............................. [ozone@10.70.47.65/block-store/4f125360-8917-497b-b67d-b7ddd766ae2e (10.0MiB) activated]
  |     o- alua ................................................................................................... [ALUA Groups: 1]
  |       o- default_tg_pt_gp ....................................................................... [ALUA state: Active/optimized]
  o- iscsi ............................................................................................................ [Targets: 2]
  | o- iqn.2016-12.org.gluster-block:4f125360-8917-497b-b67d-b7ddd766ae2e ................................................ [TPGs: 1]
  | | o- tpg1 .................................................................................................. [gen-acls, no-auth]
  | |   o- acls .......................................................................................................... [ACLs: 0]
  | |   o- luns .......................................................................................................... [LUNs: 1]
  | |   | o- lun0 .................................................................................... [user/ob2 (default_tg_pt_gp)]
  | |   o- portals .................................................................................................... [Portals: 1]
  | |     o- 10.70.47.65:3260 ................................................................................................. [OK]
  | o- iqn.2016-12.org.gluster-block:717aaa86-7efa-4dd7-94e0-19156ff23893 ................................................ [TPGs: 1]
  |   o- tpg1 .................................................................................................. [gen-acls, no-auth]
  |     o- acls .......................................................................................................... [ACLs: 0]
  |     o- luns .......................................................................................................... [LUNs: 1]
  |     | o- lun0 .................................................................................... [user/ob1 (default_tg_pt_gp)]
  |     o- portals .................................................................................................... [Portals: 1]
  |       o- 10.70.47.65:3260 ................................................................................................. [OK]
  o- loopback ......................................................................................................... [Targets: 0]
[root@dhcp47-65 ~]#
[root@dhcp47-65 ~]# mv /etc/target/saveconfig.json /home/saveconfig2.json
[root@dhcp47-65 ~]# targetcli clearconfig confirm=True
All configuration cleared
[root@dhcp47-65 ~]# targetcli restoreconfig /home/saveconfig.json 
Configuration restored, 4 recoverable errors:
Storage Object user/ob2: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob2: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped
Storage Object user/ob1: Cannot set attribute dev_size: [Errno 95] Operation not supported, skipped
Storage Object user/ob1: Cannot set attribute qfull_time_out: [Errno 22] Invalid argument, skipped
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# targetcli  / saveconfig
Configuration saved to /etc/target/saveconfig.json
[root@dhcp47-65 ~]#
[root@dhcp47-65 ~]# 
[root@dhcp47-65 ~]# diff /etc/target/saveconfig.json /home/saveconfig2.json 
[root@dhcp47-65 ~]# 

[root@dhcp47-65 ~]# rpm -qa | grep targetcli
targetcli-2.1.fb46-4.el7.noarch
[root@dhcp47-65 ~]# rpm -qa | grep python-rtslib
python-rtslib-2.1.fb63-11.el7.noarch
[root@dhcp47-65 ~]# rpm -qa | grep configshell
python-configshell-1.1.fb23-4.el7_5.noarch
[root@dhcp47-65 ~]# rpm -qa | grep gluster
glusterfs-client-xlators-3.8.4-54.8.el7rhgs.x86_64
python-gluster-3.8.4-54.8.el7rhgs.noarch
tendrl-gluster-integration-1.5.4-14.el7rhgs.noarch
gluster-nagios-addons-0.2.10-2.el7rhgs.x86_64
glusterfs-libs-3.8.4-54.8.el7rhgs.x86_64
glusterfs-fuse-3.8.4-54.8.el7rhgs.x86_64
libvirt-daemon-driver-storage-gluster-3.9.0-14.el7_5.2.x86_64
glusterfs-events-3.8.4-54.8.el7rhgs.x86_64
gluster-block-0.2.1-14.1.el7rhgs.x86_64
vdsm-gluster-4.17.33-1.2.el7rhgs.noarch
glusterfs-3.8.4-54.8.el7rhgs.x86_64
glusterfs-server-3.8.4-54.8.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-54.8.el7rhgs.x86_64
glusterfs-rdma-3.8.4-54.8.el7rhgs.x86_64
glusterfs-cli-3.8.4-54.8.el7rhgs.x86_64
gluster-nagios-common-0.2.4-1.el7rhgs.noarch
glusterfs-api-3.8.4-54.8.el7rhgs.x86_64
[root@dhcp47-65 ~]#

Comment 5 Martin Hoyer 2018-05-04 11:57:41 UTC
(In reply to Sweta Anandpara from comment #4)
Thank You very much!
Our regression tests have not found any issue on RHEL-7.5 with following
packages updated:
python-configshell-1.1.fb23-4.el7_5
python-rtslib-2.1.fb63-11.el7_5
targetcli-2.1.fb46-4.el7_5

Comment 10 errata-xmlrpc 2018-05-14 16:12:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1402


Note You need to log in before you can comment on or make changes to this bug.