Bug 1564082 - On saveconfig dump control string max_data_area_mb
Summary: On saveconfig dump control string max_data_area_mb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rtslib
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks: 1554642 1535780 1565063 1566106
TreeView+ depends on / blocked
 
Reported: 2018-04-05 10:28 UTC by Prasanna Kumar Kalever
Modified: 2018-10-30 07:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Previously, the "targetcli saveconfig" command did not save the max_data_area_mb control string. As a consequence, the property was lost when restarting the target service or rebooting the node. With this update, the property is saved and restored correctly.
Clone Of:
: 1565063 1566106 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:44:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3019 0 None None None 2018-10-30 07:45:34 UTC

Description Prasanna Kumar Kalever 2018-04-05 10:28:44 UTC
Description of problem:

saveconfig: dump control string max_data_area_mb

Problem:
-------
$ targetcli /backstores/user:glfs create blockX1 1073741824 test@192.168.124.227/block-store/e59309bb-d591-4121-a891-e98ff3416446,max_data_area_mb=32

$ targetcli / saveconfig

$ cat /etc/target/saveconfig.json
{
  "storage_objects": [
    {
      "alua_tpgs": [],
      "attributes": {
        ...
      },
      "config": "glfs/test@192.168.124.227/block-store/e59309bb-d591-4121-a891-e98ff3416446",
      "hw_max_sectors": 128,
      "name": "blockX1",
      "plugin": "user",
      "size": 1073741824,
      "wwn": "3aa072d6-a007-45a3-8eac-e85b53655515"
    }
  ],
  "targets": []
}

Note max_data_area_mb is not dumped into the configfile and hence on restart oftarget service or node reboot this storageObject property is lost.

Fix:
---
make sure to append max_data_area_mb to config param, like:
$ cat /etc/target/saveconfig.json
{
  ...
  "config": "glfs/test@192.168.124.227/block-store/e59309bb-d591-4121-a891-e98ff3416446,max_data_area_mb=32",
  ...
}

So that on restore and reboot we don't lose the property.

Comment 2 Prasanna Kumar Kalever 2018-04-05 10:29:24 UTC
Patch posted Upstream:
https://github.com/open-iscsi/rtslib-fb/pull/128

Comment 3 Prasanna Kumar Kalever 2018-04-06 08:29:01 UTC
(In reply to Prasanna Kumar Kalever from comment #2)
> Patch posted Upstream:
> https://github.com/open-iscsi/rtslib-fb/pull/128

In addition to above PR we also need:
https://github.com/open-iscsi/targetcli-fb/pull/109

Comment 8 Martin Hoyer 2018-07-10 07:58:13 UTC
Tested with: 
 - kernel-3.10.0-915.el7
 - targetcli-2.1.fb46-6.el7
 - python-configshell-1.1.fb23-4.el7
 - python-rtslib-2.1.fb63-12.el7
The issue is no longer reproducible; No regression found.

Comment 10 errata-xmlrpc 2018-10-30 07:44:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3019


Note You need to log in before you can comment on or make changes to this bug.