Bug 1565063 - targetcli: On saveconfig dump control string max_data_area_mb
Summary: targetcli: On saveconfig dump control string max_data_area_mb
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetcli
Version: 7.5
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On: 1564082
Blocks: 1554642 1535780 1566107
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:52 UTC by Maurizio Lombardi
Modified: 2018-10-30 07:56 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Previously, the "targetcli saveconfig" command did not save the max_data_area_mb control string. As a consequence, the property was lost when restarting the target service or rebooting the node. With this update, the property is saved and restored correctly.
Clone Of: 1564082
: 1566107 (view as bug list)
Environment:
Last Closed: 2018-10-30 07:55:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3040 0 None None None 2018-10-30 07:56:11 UTC

Comment 2 Prasanna Kumar Kalever 2018-04-09 15:25:09 UTC
PR:
https://github.com/open-iscsi/targetcli-fb/pull/109

Comment 7 Martin Hoyer 2018-07-10 10:22:32 UTC
Tested with: 
 - kernel-3.10.0-915.el7
 - targetcli-2.1.fb46-6.el7
 - python-configshell-1.1.fb23-4.el7
 - python-rtslib-2.1.fb63-12.el7
The issue is no longer reproducible; No regression found.

Comment 9 errata-xmlrpc 2018-10-30 07:55:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3040


Note You need to log in before you can comment on or make changes to this bug.