Bug 1564239 - [RFE] CFME 5.9.3 - Validating VM import from .csv
Summary: [RFE] CFME 5.9.3 - Validating VM import from .csv
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: GA
: 5.10.0
Assignee: Marco Berube
QA Contact: Yadnyawalk Tale
Steve Bream
URL:
Whiteboard: v2v
Depends On:
Blocks: 1564234 1588570
TreeView+ depends on / blocked
 
Reported: 2018-04-05 19:11 UTC by Brett Thurber
Modified: 2019-02-11 14:00 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1588570 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:00:59 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
fixed_proof.png (122.83 KB, image/png)
2018-07-24 09:21 UTC, Yadnyawalk Tale
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/priley86 miq_v2v_ui_plugin pull 239 0 None None None 2018-05-16 02:31:26 UTC

Description Brett Thurber 2018-04-05 19:11:08 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2018-04-05 19:45:33 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Dave Johnson 2018-04-05 20:04:21 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 4 Brett Thurber 2018-05-16 02:31:26 UTC
Feature complete and verified.

Comment 6 Yadnyawalk Tale 2018-07-24 09:21:58 UTC
Created attachment 1470239 [details]
fixed_proof.png

Fixed! great work for csv import errors! 

Checked with,
1. if .csv is blank
2. if header is diff than `Name` and `Provider`
3. if we got 2+ arguments

In VM Table, checked with, 
1. if vm exists in diff migration plan
2. if empty vm name specified
3. if vm available
4. if vm does not exist

All above works perfectly, BZ1589212 also seems to be patched on lastest 5.10 build.
Verified on: 5.10.0.4.20180712211305_e6e4542 

Thanks!


Note You need to log in before you can comment on or make changes to this bug.