Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1564546 - hammer host/content-host optimization
Summary: hammer host/content-host optimization
Keywords:
Status: CLOSED DUPLICATE of bug 1564547
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 15:16 UTC by François Cami
Modified: 2018-04-10 15:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:57:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description François Cami 2018-04-06 15:16:25 UTC
Description of problem:
Running:
"hammer content-host list --organization-id 1 --search 'name !~ virt-who"
or "hammer host..." takes too long.

Version-Release number of selected component (if applicable):
Satellite 6.2.13
Satellite 6.3.x

How reproducible:
Always

Steps to Reproduce:
1. Register 10K hosts to Satellite
2. Run the above command

Actual results:
Loooong wait, sometimes even timeouts

Expected results:
A list of hosts in a reasonable timeframe (<30s?)

Comment 1 Brad Buckingham 2018-04-10 15:57:45 UTC
Closing this one, since it appears to be exact duplicate of bug 1564547.

*** This bug has been marked as a duplicate of bug 1564547 ***


Note You need to log in before you can comment on or make changes to this bug.