Bug 1564547 - hammer host/content-host is too slow
Summary: hammer host/content-host is too slow
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: tstrych
URL:
Whiteboard:
: 1564546 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 15:18 UTC by François Cami
Modified: 2019-12-03 12:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description François Cami 2018-04-06 15:18:25 UTC
Description of problem:
Running:
"hammer content-host list --organization-id 1 --search 'name !~ virt-who"
or "hammer host..." takes too long.

Version-Release number of selected component (if applicable):
Satellite 6.2.13
Satellite 6.3.x

How reproducible:
Always

Steps to Reproduce:
1. Register 10K hosts to Satellite
2. Run the above command

Actual results:
Loooong wait, sometimes even timeouts

Expected results:
A list of hosts in a reasonable timeframe (<30s?)

Comment 3 Brad Buckingham 2018-04-10 15:57:45 UTC
*** Bug 1564546 has been marked as a duplicate of this bug. ***

Comment 8 Bryan Kearney 2019-11-04 14:34:03 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 9 Bryan Kearney 2019-12-03 12:53:35 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.