Bug 1564735 - subscription-manager-rhsm subpackage has been dropped on Fedora 27
Summary: subscription-manager-rhsm subpackage has been dropped on Fedora 27
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: 27
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: candlepin-bugs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1565112 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-07 08:37 UTC by Ondřej Lysoněk
Modified: 2018-11-15 03:14 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.24.2-1.fc27 subscription-manager-1.24.2-1.fc28 subscription-manager-1.24.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-15 02:12:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Ondřej Lysoněk 2018-04-07 08:37:29 UTC
Description of problem:
The subscription-manager-rhsm subpackage has been dropped on Fedora 27. Please don't drop packages in stable releases unless completely necessary, especially when there are packages depending on them:
$ rpm -q --whatrequires python-rhsm
virt-who-0.17-4.fc27.noarch
$ rpm -q --whatprovides python-rhsm
subscription-manager-rhsm-1.21.1-1.fc27.x86_64

And when you do remove packages, add proper Obsoletes/Provides as appropriate (https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Renaming.2FReplacing_Existing_Packages). I presume the python3-subscription-manager-rhsm subpackage is supposed to replace subscription-manager-rhsm, but it doesn't have proper Obsoletes:
https://koji.fedoraproject.org/koji/rpminfo?rpmID=13216072

Please readd the package or coordinate with maintainers of dependent packages to change their dependencies.

Version-Release number of selected component (if applicable):
subscription-manager-1.21.2-3.fc27.x86_64

Comment 1 Alex Wood 2018-04-09 14:04:01 UTC
*** Bug 1565112 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2018-11-05 22:55:22 UTC
subscription-manager-1.24.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-075821dc8f

Comment 4 Fedora Update System 2018-11-05 22:56:00 UTC
subscription-manager-1.24.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a675aa39fc

Comment 5 Fedora Update System 2018-11-05 22:56:43 UTC
subscription-manager-1.24.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-91ba32a0ff

Comment 6 Fedora Update System 2018-11-06 22:01:56 UTC
subscription-manager-1.24.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-075821dc8f

Comment 7 Fedora Update System 2018-11-06 22:45:48 UTC
subscription-manager-1.24.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-91ba32a0ff

Comment 8 Fedora Update System 2018-11-06 23:28:24 UTC
subscription-manager-1.24.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a675aa39fc

Comment 9 Fedora Update System 2018-11-15 02:12:26 UTC
subscription-manager-1.24.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-11-15 02:28:47 UTC
subscription-manager-1.24.2-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-11-15 03:14:22 UTC
subscription-manager-1.24.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.