Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565112 - Upgrade from F27 to F28 broken
Summary: Upgrade from F27 to F28 broken
Keywords:
Status: CLOSED DUPLICATE of bug 1564735
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: candlepin-bugs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 12:22 UTC by Miroslav Suchý
Modified: 2018-05-02 13:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 14:04:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Miroslav Suchý 2018-04-09 12:22:33 UTC
When I run:
  sudo dnf dist-upgrade   --releasever=28  --enablerepo=updates-testing

I get:

  Problém 3: package subscription-manager-rhsm-1.21.1-1.fc27.x86_64 requires subscription-manager-rhsm-certificates = 1.21.1-1.fc27, but none of the providers can be installed
  - subscription-manager-rhsm-certificates-1.21.1-1.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package subscription-manager-rhsm-1.21.1-1.fc27.x86_64

This is because subscription-manager-rhsm no longer exist. But you cannot just stop building the package. Either one of your package should obsolete it or ask maintainer of package `fedora-obsolete` to add Obsoletes of your package.

See
https://fedoraproject.org/wiki/Upgrade_paths_%E2%80%94_renaming_or_splitting_packages

Comment 1 Alex Wood 2018-04-09 14:04:01 UTC

*** This bug has been marked as a duplicate of bug 1564735 ***


Note You need to log in before you can comment on or make changes to this bug.