Bug 1564747 - freeipa-client-common conflicts with ipa-client-common-4.5.0-22.el7.centos.noarch
Summary: freeipa-client-common conflicts with ipa-client-common-4.5.0-22.el7.centos.no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum
Version: 7.3
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Michal Domonkos
QA Contact: Jan Blazek
URL:
Whiteboard:
: 1653364 (view as bug list)
Depends On:
Blocks: 1630909 1716964
TreeView+ depends on / blocked
 
Reported: 2018-04-07 12:06 UTC by lejeczek
Modified: 2021-01-25 09:21 UTC (History)
14 users (show)

Fixed In Version: yum-3.4.3-164.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-31 20:03:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1693212 0 medium CLOSED Reinstall with --replacepkgs fails on packages with self-conflicts 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2020:1122 0 None None None 2020-03-31 20:03:49 UTC

Internal Links: 1693212

Description lejeczek 2018-04-07 12:06:58 UTC
Description of problem:

$ yum reinstall -y ipa-client-common-4.5.0-22.el7.centos.noarch.rpm 
Loaded plugins: fastestmirror, langpacks, post-transaction-actions, product-id, search-disabled-repos,
              : subscription-manager, tsflags
This system is not registered with an entitlement server. You can use subscription-manager to register.
Examining ipa-client-common-4.5.0-22.el7.centos.noarch.rpm: ipa-client-common-4.5.0-22.el7.centos.noarch
Resolving Dependencies
--> Running transaction check
---> Package ipa-client-common.noarch 0:4.5.0-22.el7.centos will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================
 Package             Arch     Version                  Repository                                       Size
=============================================================================================================
Reinstalling:
 ipa-client-common   noarch   4.5.0-22.el7.centos      /ipa-client-common-4.5.0-22.el7.centos.noarch    44 k

Transaction Summary
=============================================================================================================
Reinstall  1 Package

Total size: 44 k
Installed size: 44 k
Downloading packages:
Running transaction check
ERROR with transaction check vs depsolve:
freeipa-client-common conflicts with ipa-client-common-4.5.0-22.el7.centos.noarch
freeipa-client-common conflicts with (installed) ipa-client-common-4.5.0-22.el7.centos.noarch

..and

★ RIDER 100 ~]$ rpm -Uv --force ipa-client-common-4.5.0-22.el7.centos.noarch.rpm
error: Failed dependencies:
	freeipa-client-common conflicts with ipa-client-common-4.5.0-22.el7.centos.noarch
	freeipa-client-common conflicts with (installed) ipa-client-common-4.5.0-22.el7.centos.noarch


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Florence Blanc-Renaud 2018-05-30 07:09:55 UTC
This looks like an issue in yum for me. IPA packages on fedora are named freeipa-server, freeipa-client etc... while in RHEL they are named ipa-server, ipa-client etc...

ipa.spec defines on purpose conflicts with freeipa-* packages from fedora:

%global alt_name freeipa

Provides: %{alt_name}-server = %{version}
Conflicts: %{alt_name}-server
Obsoletes: %{alt_name}-server < %{version}

It looks like yum is not able to handle this situation, hence moving this issue to yum component.

Comment 3 Karel Srot 2018-11-12 08:41:08 UTC
Looks that this is the problem

# rpm -q --provides ipa-client-common
config(ipa-client-common) = 4.6.4-10.el7
freeipa-client-common = 4.6.4
ipa-client-common = 4.6.4-10.el7
# rpm -q --conflicts ipa-client-common
freeipa-client-common

on reinstall the package conflicts with its own provides. yum should not be considering such conflicts valid.

Comment 4 Michal Domonkos 2018-11-22 14:28:11 UTC
Which yum version is this?  The issue has been fixed in yum-3.4.3-154.el7 shipped with RHEL-7.4.  Could you please update yum to that version and try again?

Comment 5 Karel Srot 2018-11-22 14:57:59 UTC
yum-3.4.3-161.el7.noarch

Comment 6 Michal Domonkos 2018-11-26 09:48:51 UTC
OK, I can reproduce this.  Turns out the previous fix (bug 1370134) only covers some code paths (such as "yum check") but not this one.  We'll consider this for 7.7.

Comment 7 Florence Blanc-Renaud 2018-11-30 09:50:18 UTC
*** Bug 1653364 has been marked as a duplicate of this bug. ***

Comment 9 Panu Matilainen 2019-03-25 10:38:03 UTC
That'd be an rpm bug. There's an unhandled corner-case with self-conflicts on (re)installation of already installed packages and that affects upstream rpm too. I've a preliminary fix for this, and what I have now is not an intrusive patch so it could be considered for rhel-7:
 3 files changed, 21 insertions(+), 5 deletions(-)

Now I'll just need to mull over it a bit to understand whether this fix is actually the right thing to do, there are a few different approaches possible and it's all a bit subtle.

Comment 23 Michal Domonkos 2019-08-23 17:24:57 UTC
Upstream PR:
https://github.com/rpm-software-management/yum/pull/101

Comment 30 errata-xmlrpc 2020-03-31 20:03:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1122


Note You need to log in before you can comment on or make changes to this bug.