Bug 1653364 - ipa-* conflicts with itself and can not be reinstalled because of this
Summary: ipa-* conflicts with itself and can not be reinstalled because of this
Keywords:
Status: CLOSED DUPLICATE of bug 1564747
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.6
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-26 16:17 UTC by jcastran
Modified: 2018-11-30 09:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 09:50:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jcastran 2018-11-26 16:17:08 UTC
Description of problem:
ipa-* packages can not be reinstalled due to conflicts.

Version-Release number of selected component (if applicable):
ipa-client-4.6.4-10.el7.x86_64
ipa-client-common-4.6.4-10.el7.noarch
ipa-common-4.6.4-10.el7.noarch
ipa-server-4.6.4-10.el7.x86_64
ipa-server-common-4.6.4-10.el7.noarch


How reproducible:
Everytime

Steps to Reproduce:
# yum install ipa-client-4.6.4-10.el7.x86_64 ipa-client-common-4.6.4-10.el7.noarch ipa-common-4.6.4- 
 10.el7.noarch ipa-server-4.6.4-10.el7.x86_64 ipa-server-common-4.6.4-10.el7.noarch

# yum reinstall ipa-client-4.6.4-10.el7.x86_64 ipa-client-common-4.6.4-10.el7.noarch ipa-common-4.6.4-10.el7.noarch ipa-server-4.6.4-10.el7.x86_64 ipa-server-common-4.6.4-10.el7.noarch

Actual results:
Running transaction check
ERROR with transaction check vs depsolve:
freeipa-common conflicts with (installed) ipa-common-4.6.4-10.el7.noarch
freeipa-server-common conflicts with ipa-server-common-4.6.4-10.el7.noarch
freeipa-server-common conflicts with (installed) ipa-server-common-4.6.4-10.el7.noarch
freeipa-client-common conflicts with ipa-client-common-4.6.4-10.el7.noarch
freeipa-client-common conflicts with (installed) ipa-client-common-4.6.4-10.el7.noarch
freeipa-client conflicts with ipa-client-4.6.4-10.el7.x86_64
freeipa-admintools conflicts with ipa-client-4.6.4-10.el7.x86_64
freeipa-admintools conflicts with (installed) ipa-client-4.6.4-10.el7.x86_64
freeipa-client conflicts with (installed) ipa-client-4.6.4-10.el7.x86_64
freeipa-server conflicts with ipa-server-4.6.4-10.el7.x86_64
freeipa-server conflicts with (installed) ipa-server-4.6.4-10.el7.x86_64


Expected results:
yum reinstalls the packages successfully

Additional info:
The only way to reinstall these packages is to either remove them and reinstall them 
OR you can use rpm but you must use --nodeps and --force to reinstall them.

FAIL:
# rpm -Uvh --force ipa-server-4.6.4-10.el7.x86_64.rpm 
  error: Failed dependencies:
	  freeipa-server conflicts with ipa-server-4.6.4-10.el7.x86_64
	  freeipa-server conflicts with (installed) ipa-server-4.6.4-10.el7.x86_64

WORKING:
# rpm -Uvh --force --nodeps ipa-server-4.6.4-10.el7.x86_64.rpm 
  Preparing...                          ################################# [100%]
  Updating / installing...
     1:ipa-server-4.6.4-10.el7          ################################# [100%]

Comment 4 Florence Blanc-Renaud 2018-11-28 16:01:30 UTC
The issue related to reinstall complaining about conflicts has already been reported, please see BZ 1564747 and BZ 1370134.

Which version of yum is installed on the system?

Comment 5 jcastran 2018-11-28 16:07:41 UTC
This is the same issue with 1564747 though that one is talking about centos. Root cause is probably the same.

   yum-3.4.3-161.el7.noarch

Latest version of yum so "package-cleanup --problems" and "yum check" don't show anything about the conflicts. Only yum's transaction depsolve check finds them and stops the transaction.

Comment 6 Florence Blanc-Renaud 2018-11-30 09:50:18 UTC
Thanks for the confirmation. In this case I will close this issue as a duplicate of 1564747.

*** This bug has been marked as a duplicate of bug 1564747 ***


Note You need to log in before you can comment on or make changes to this bug.