Bug 1564888 - Blueman and added widgets in panel crashed after upgrading to kernel 4.15.14
Summary: Blueman and added widgets in panel crashed after upgrading to kernel 4.15.14
Keywords:
Status: CLOSED DUPLICATE of bug 1568911
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 16:16 UTC by Neyzan
Modified: 2018-04-23 13:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 13:18:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Neyzan 2018-04-08 16:16:27 UTC
Description of problem:
After upgrading the kernel to 4.15.14 and restarting the system I found all widgets I added in the panel removed (but not colour and style personalisation) and Blueman stopped functioning. In blueman's screen no devices were showing and the "Adaptor" and "Device" options in the toolbar were greyed out.
Other personal settings, such as recent documents in LibreOffice or browser history, were not affected.
Also, after re-adding the lost widgets to the panel in 4.15.13 they remained even after rebooting into 4.15.14, but blueman again stopped functioning.

Version-Release number of selected component (if applicable):
Distribution & Version: Fedora 27
Kernel: 4.15.14
Qt Version: 5.9.4
liblxqt Version: 0.11.1.7
Package version: 2.1.0.8alpha2 (Blueman), 5.48.3 (Bluez)

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
I have reported this also at the LXQt bugtracker:
https://github.com/lxqt/lxqt/issues/1472

Comment 1 Neyzan 2018-04-11 16:56:02 UTC
I upgraded to kernel 4.15.15 but the issue persists.

Comment 2 Neyzan 2018-04-21 12:28:11 UTC
I 've also reported this at Blueman's GitHub page:
https://github.com/blueman-project/blueman/issues/862

I hope the below provide adequate info. If not, please inform me what else is needed and how I may retrieve it.

-------------

Update after upgrading to Linux Kernel 4.15.17:
**Issue persists**

-------------

Debug output:

```
[root@192 ~]# blueman-applet --loglevel debug
blueman-applet version 2.1.alpha1 starting
blueman-applet 12.58.03 INFO     PluginManager:85 Load      : ['KillSwitch', 'NetUsage', 'ExitItem', 'PPPSupport', 'DhcpClient', 'StatusIcon', 'ShowConnected', 'AuthAgent', 'SerialManager', 'NMDUNSupport', 'DiscvManager', 'Networking', 'GameControllerWakelock', 'PowerManager', 'NMPANSupport', 'StandardItems', 'RecentConns', 'Menu', 'TransferService', 'DBusService']
blueman-applet 12.58.03 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.Menu.Menu'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.StatusIcon.StatusIcon'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.PowerManager.PowerManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.KillSwitch.KillSwitch'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.ExitItem.ExitItem'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.DBusService.DBusService'>
blueman-applet 12.58.04 WARNING  PluginManager:146 __load_plugin: Not loading PPPSupport because its conflict has higher priority
blueman-applet 12.58.04 WARNING  PluginManager:146 __load_plugin: Not loading DhcpClient because its conflict has higher priority
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.ShowConnected.ShowConnected'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.AuthAgent.AuthAgent'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.SerialManager.SerialManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.NMDUNSupport.NMDUNSupport'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.DiscvManager.DiscvManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.Networking.Networking'>
blueman-applet 12.58.04 INFO     Networking:31 load_nap_settings: Loading NAP settings
blueman-tray version 2.1.alpha1 starting
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.GameControllerWakelock.GameControllerWakelock'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.NMPANSupport.NMPANSupport'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.StandardItems.StandardItems'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.RecentConns.RecentConns'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.TransferService.TransferService'>
blueman-applet 12.58.04 INFO     KillSwitch:104 io_event  : killswitch registered 1
blueman-applet 12.58.04 INFO     KillSwitch:120 io_event  : State: True
blueman-applet 12.58.04 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
blueman-applet 12.58.04 INFO     KillSwitch:104 io_event  : killswitch registered 2
blueman-applet 12.58.04 INFO     KillSwitch:120 io_event  : State: True
blueman-applet 12.58.04 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
blueman-applet 12.58.04 INFO     KillSwitch:85 _on_connman_vanished: net.connman vanished
blueman-applet 12.58.04 INFO     Applet:47 _on_dbus_name_appeared: org.bluez :1.0
blueman-applet 12.58.04 INFO     BluezAgent:78 register_agent: Register Agent
blueman-applet 12.58.04 ERROR    PluginManager:209 Run       : Function on_manager_state_changed on DiscvManager failed
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/blueman/main/PluginManager.py", line 206, in Run
    ret = getattr(inst, func)(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blueman/plugins/applet/DiscvManager.py", line 47, in on_manager_state_changed
    self.init_adapter()
  File "/usr/lib/python3.6/site-packages/blueman/plugins/applet/DiscvManager.py", line 67, in init_adapter
    self.adapter = self.parent.Manager.get_adapter()
  File "/usr/lib/python3.6/site-packages/blueman/bluez/Manager.py", line 85, in get_adapter
    raise DBusNoSuchAdapterError("No adapter(s) found")
blueman.bluez.errors.DBusNoSuchAdapterError: No adapter(s) found
blueman-applet 12.58.04 INFO     Networking:68 set_nap   : set nap False
blueman-applet 12.58.04 INFO     RecentConns:97 initialize: rebuilding menu
blueman-applet 12.58.04 INFO     ShowConnected:38 enumerate_connections: Found 0 existing connections
blueman-applet 12.58.04 INFO     TransferService:193 _on_dbus_name_vanished: org.bluez.obex not running or was stopped
blueman-applet 12.58.05 INFO     PowerManager:120 RequestPowerState: Requesting True
blueman-applet 12.58.05 INFO     KillSwitch:136 on_power_state_change_requested: True
blueman-applet 12.58.05 DEBUG    KillSwitch:149 on_power_state_change_requested: Using mechanism to set state: True
blueman-applet 12.58.05 INFO     PowerManager:105 check     : callbacks done
blueman-applet 12.58.05 INFO     PowerManager:76 set_adapter_state: True
blueman-applet 12.58.05 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
```

------------

Furthermore, "bluetoothctl list" gave no output, although Airplane mode is off (other networking methods function normally).

------------

Running "bluetoothctl":

```
[bluetooth]# pair
Missing device address argument
[bluetooth]# head -1 $(which blueman-applet)
[bluetooth]#
```

Comment 3 Neyzan 2018-04-22 10:57:06 UTC
This seems to originate in this bug, so it's probably a kernel issue:
https://bugzilla.kernel.org/show_bug.cgi?id=199271

Comment 4 Raphael Groner 2018-04-23 05:57:52 UTC
As upstream confirms, I'll reassign to maintainers of kernel firmware. Though, no idea what concrete kernel module is responsible for bluetooth firmware.

Comment 5 Laura Abbott 2018-04-23 13:18:35 UTC

*** This bug has been marked as a duplicate of bug 1568911 ***


Note You need to log in before you can comment on or make changes to this bug.